Bug 31929 - Пакет perl-Pod-Usage 1.64-alt1 не содержит зависимость от perl-podlators
: Пакет perl-Pod-Usage 1.64-alt1 не содержит зависимость от perl-podlators
Status: NEW
: ALT Linux Centaurus
(All bugs in ALT Linux Centaurus/Состав)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-03-29 20:49 by
Modified: 2016-03-29 20:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-03-29 20:49:54
$ cat /etc/altlinux-release 
ALT Linux 7.0.5 Centaurus  (Pholus)

При установке выбраны компоненты почтового сервера, остальные "офисные" были
выключены.
При запуске sa-learn выскакивает ошибка:
============================
Can't locate Pod/Text.pm in @INC (@INC contains: /usr/local/lib64/perl/5.16
/usr/local/share/perl/5.16 /usr/lib64/perl5 /usr/share/perl5 /usr/lib64/perl5
/usr/share/perl5 /etc/perl5 /usr/lib/perl5/vendor_perl) at (eval 2) line 2.
BEGIN failed--compilation aborted at /usr/share/perl5/Pod/Usage.pm line 29.
Compilation failed in require at /usr/bin/sa-learn line 24.
BEGIN failed--compilation aborted at /usr/bin/sa-learn line 24.
============================
После этого я установил все пакеты perl-Pod-* и тогда выяснил, какой пакет не
установился по зависимости:
$ rpm -qf /usr/share/perl5/Pod/Text.pm
perl-podlators-2.5.3-alt0.M70P.1

IMHO надо модифицировать пакет perl-Pod-Usage 1.64 в ветке P7 - добавить в спек
зависимость.