Bug 32306 - Нужно обновить до версии 0.1.9 из-за версии xrandr 1.5
: Нужно обновить до версии 0.1.9 из-за версии xrandr 1.5
Status: CLOSED FIXED
: Branch p8
(All bugs in Branch p8/arandr)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-07-23 01:59 by
Modified: 2016-07-25 15:23 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-07-23 01:59:35
При запуске :
 $  arandr 
Traceback (most recent call last):
  File "/usr/bin/arandr", line 42, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/screenlayout/gui.py", line 319, in
main
    force_version=options.force_version
  File "/usr/lib/python2.7/site-packages/screenlayout/gui.py", line 157, in
__init__
    self.widget = widget.ARandRWidget(display=randr_display,
force_version=force_version)
  File "/usr/lib/python2.7/site-packages/screenlayout/widget.py", line 48, in
__init__
    self._xrandr = XRandR(display=display, force_version=force_version)
  File "/usr/lib/python2.7/site-packages/screenlayout/xrandr.py", line 45, in
__init__
    raise Exception("XRandR 1.2/1.3 required.")
Exception: XRandR 1.2/1.3 required.

$  xrandr -v  
xrandr program version       1.5.0
Server reports RandR version 1.5

Судя по git https://alioth.debian.org/scm/browser.php?group_id=100834
поддержка появляется в 0.1.9
------- Comment #1 From 2016-07-25 15:23:23 -------
Скопировал.

p8 Branch
arandr-0.1.9-alt1
Sisyphus
arandr-0.1.9-alt1