Bug 32398 - doesn't open many HTTPS sites becuase requires fresh libs
: doesn't open many HTTPS sites becuase requires fresh libs
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/firefox)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 32399
  Show dependency tree
 
Reported: 2016-08-19 18:28 by
Modified: 2016-08-19 19:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-08-19 18:28:35
firefox-48.0-alt1

Firefox doesn't open many HTTPS sites after "apt-get install firefox" in
basealt-p8-wmaker-20160612-i586.iso -- probably, because requires fresh libs,
but this is not written in its formal deps.

Examples: https://mozilla.org (a greeting page), https://google.com ,
https://gmail.com .

Workaround: apt-get dist-upgrade
------- Comment #1 From 2016-08-19 18:44:41 -------
It happens because you need to update libnss and get a new certificates. It's
not a firefox problem.
------- Comment #2 From 2016-08-19 19:45:37 -------
(In reply to comment #1)
> It happens because you need to update libnss and get a new certificates. It's
> not a firefox problem.

So, the new firefox doesn't work with the older libnss package. But, if libnss
package is updated, firefox works.

How is this different from a case when a package has Requires: libXYZ >=
1-alt2?

Why wouldn't such a dependency in the firefox package be correct?
------- Comment #3 From 2016-08-19 19:49:19 -------
BTW, seamonkey from the same 2016-June distro works, and opens those sites.

So, it's not a problem of libnss per se, because it works with these sites if
used from within Seamonkey. But not from within the newer Firefox.