Bug 32478 - many pkgs have unjustified deps on ipython
: many pkgs have unjustified deps on ipython
Status: NEW
: Sisyphus
(All bugs in Sisyphus/ipython)
: unstable
: all Linux
: P3 minor
Assigned To:
:
:
:
: 32477
:
  Show dependency tree
 
Reported: 2016-09-07 15:11 by
Modified: 2016-09-07 15:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-09-07 15:11:53
+++ This bug was initially created as a clone of Bug #32477 +++

Many pkgs have autodeps on ipython, which are not justified, because they
simply provide ipython-plugins, which can be used if ipython is installed, but
are "ignored" otherwise.

Something has to be done (rules in rpm-build-python or fixing of the individual
pkgs).

apt> whatdepends ipython
ipython-4.0.0-alt3.1.1
  python-module-plotly-1.6.6-alt2.1
    Depends: <python2.7(IPython.html)>
      ipython-4.0.0-alt3.1.1
  python-module-spyderlib-2.3.8-alt1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-pyface-4.6.0-alt1.git20150401
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-pandas-highcharts-0.3.0-alt1.git20150228.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-oct2py-1.5.0-alt2.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-notebook-4.0.4-alt2.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-nbconvert-4.0.0-alt2.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-jupyter_console-4.1.0-alt1.dev.git20150812.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-ipyparallel-4.1.0-alt1.dev.git20150819.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-ipykernel-4.0.3-alt2.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-ipdb-0.8.1-alt1.dev0.git20130919.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-envisage-4.5.0-alt1.git20150428
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-dautil-0.0.1-alt1.a18.2
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-TraitsBackendWX-3.6.1-alt1.svn20110127.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  ptpython-0.20-alt1.git20150808.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-psychopy-1.82.01-alt1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-sfepy-2015.1-alt1.git20150427.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-rpy2-2.7.8-alt1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-rasterio-0.26.0-alt1.git20150811.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-pyannote.core-0.3.4-alt1.git20150304
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-PyQwt-5.2.0-alt3
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  python-module-PyMca-5.0.0-alt1.git20150221.1.1
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  kde4-kate-4.14.7-alt2
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
  fontforge-20150612-alt0.3
    Depends: <python2.7(IPython)>
      ipython-4.0.0-alt3.1.1
apt>
------- Comment #1 From 2016-09-07 15:13:39 -------
This is one of casuse for "apt-get install grass" wanting to install many a lot
of python pkgs.