Bug 32775 - docbook/xml/4.0/docbookx.dtd is not provided, but required by some builds
: docbook/xml/4.0/docbookx.dtd is not provided, but required by some builds
Status: NEW
: Sisyphus
(All bugs in Sisyphus/docbook-dtds)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-11-21 01:34 by
Modified: 2016-11-23 19:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-11-21 01:34:39
docbook-dtds-4.5-alt1

From the build log of pam_pkcs11-0.6.9-alt2:


make[2]: Entering directory `/usr/src/RPM/BUILD/pam_pkcs11-0.6.9/doc'
xsltproc \
--stringparam  section.autolabel 1 \
--stringparam  section.label.includes.component.label 1 \
-o pam_pkcs11.html pam_pkcs11.xsl pam_pkcs11.xml
error : Resource temporarily unavailable
pam_pkcs11.xml:2: I/O warning : failed to load external entity
"http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"
DocBook XML V4.1.2//EN"
"http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"
                                                                              
^
pam_pkcs11.xml:2: warning: failed to load external entity
"http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"
DocBook XML V4.1.2//EN"
"http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"
                                                                              
^
Can docbook-dtds provide the needed DTD, too?

Now it provides some other ones:


$ fgrep docbookx.dtd /ALT/Sisyphus/{noarch,x86_64}/base/contents_index 
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/findbugs/etc/docbook/docbookx.dtd
   findbugs
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/sgml/docbook/dtd/4.2/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/sgml/docbook/dtd/4.3/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/sgml/docbook/dtd/4.4/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/sgml/docbook/dtd/4.5/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/xml/docbook/dtd/4.1.2/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/xml/docbook/dtd/4.2/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/xml/docbook/dtd/4.3/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/xml/docbook/dtd/4.4/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/noarch/base/contents_index:/usr/share/xml/docbook/dtd/4.5/docbookx.dtd
   docbook-dtds
/ALT/Sisyphus/x86_64/base/contents_index:/usr/share/kde/apps/ksgmltools2/docbook/xml-dtd-4.1.2/docbookx.dtd
   kdelibs
/ALT/Sisyphus/x86_64/base/contents_index:/usr/share/kde/apps/ksgmltools2/docbook/xml-dtd-4.2/docbookx.dtd
   kdelibs
/ALT/Sisyphus/x86_64/base/contents_index:/usr/share/yelp/dtd/docbookx.dtd   
yelp
------- Comment #1 From 2016-11-21 02:06:11 -------
(В ответ на комментарий №0)
> docbook-dtds-4.5-alt1
> 
> From the build log of pam_pkcs11-0.6.9-alt2:
....
> pam_pkcs11.xml:2: warning: failed to load external entity
> "http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"
> DocBook XML V4.1.2//EN"
^^^^^^^^^^^^^^^^^^^^^^^^^^^^
4.1.2 есть.
------- Comment #2 From 2016-11-21 02:13:41 -------
(In reply to comment #1)
> (В ответ на комментарий №0)
> > docbook-dtds-4.5-alt1
> > 
> > From the build log of pam_pkcs11-0.6.9-alt2:
> ....
> > pam_pkcs11.xml:2: warning: failed to load external entity
> > "http://www.oasis-open.org/docbook/xml/4.0/docbookx.dtd"

Я вот пока не разобрался, что же пошло не так.

Здесь в пути почему-то 4.0 написано в сообщении об ошибке.

Попробую разобраться, помотреть исходники и как это работает.

> > DocBook XML V4.1.2//EN"
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> 4.1.2 есть.