Bug 32808 - Добавить в зависимости libusb
: Добавить в зависимости libusb
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/haspd)
: unstable
: x86 Linux
: P3 minor
Assigned To:
:
:
:
:
: 30940
  Show dependency tree
 
Reported: 2016-11-25 13:51 by
Modified: 2016-11-26 13:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-11-25 13:51:05
При установке пакета i586-haspd (i586-haspd-7.40-alt4) на P8 x64 автоматом не
устанавливаются нужные для работы службы haspd дополнительные библиотеки

Вот все что нужны:
i586-glibc-core.32bit
i586-glibc-pthread.32bit
i586-libgcc1.32bit
i586-libudev1.32bit
i586-libusb.32bit

Без этих библиотек будет ругань при запуске службы haspd и она упадет с
ошибкой.

Running aksusbd... /etc/init.d/haspd: line 221: /usr/sbin/aksusbd: Нет такого
файла или каталога

Достаточно прописать в зависимостях только i586-libusb.32bit остальные
подтянутся.

Эти библиотеки подтягиваются обычно при установке серверной части 1С если
ставить сервер 1С из rpm-ников через apt, но в случае когда нужно крутить haspd
с ключами на отдельной машине без установленного сервера 1С придется их
установить вручную, причем по ошибке что именно нужно ставить не очевидно.
------- Comment #1 From 2016-11-25 14:29:57 -------
i586-ibusb добавить не получится, т.к. это зависимости в сгенерированном пакете
(см. http://altlinux.org/biarch); а вот в p8/i586/RPMS/haspd-7.40-alt4.i586.rpm
зависимости на libusb и впрямь не хватает, получается.  Перевешиваю на сизиф.

Спасибо!
------- Comment #2 From 2016-11-25 16:52:59 -------
Исправлено в haspd-7.40-alt4.1
------- Comment #3 From 2016-11-25 16:57:21 -------
выглядит хак-то так:
http://git.altlinux.org/people/cas/packages/?p=haspd.git;a=commitdiff;h=267e3948f925f33b04f6dd430232c9f4c5f966d6
------- Comment #4 From 2016-11-26 13:48:26 -------
Я плохо умею потом мержить.

commit 574df0f0fdc464547e51831b93d3391c8a9d6b52
Merge: 1ec869a 267e394
Author: Vitaly Lipatov <lav@etersoft.ru>
Date:   Fri Nov 25 23:06:18 2016 +0300

    Merge remote-tracking branch 'gear/sisyphus'

commit 1ec869a7ac43c7f2fe651acb121b407fde3c42d7
Author: Vitaly Lipatov <lav@etersoft.ru>
Date:   Fri Nov 25 23:05:02 2016 +0300

    7.40-alt10

    - require i586-libusb in ALT Linux arepo (ALT bug 32808) (thanks, cas@)