Bug 32929 - Собрать xfce4-terminal с libvte3 в p8
: Собрать xfce4-terminal с libvte3 в p8
Status: CLOSED WONTFIX
: Branch p8
(All bugs in Branch p8/xfce4-terminal)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
: 32252
:
  Show dependency tree
 
Reported: 2016-12-21 10:07 by
Modified: 2017-01-25 21:26 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-12-21 10:07:57
В Сизифе xfce4-terminal, начиная с 0.6.90-alt1, собран с libvte3, исправляющей
проблему со вставкой из буфера обмена после запуска mc.
------- Comment #1 From 2016-12-21 17:37:32 -------
xfce4-terminal написан на gtk3. Чтобы не делать ползущую миграцию на gtk3,
пересобирать не будем. Как вариант - патчить старую версию.
------- Comment #2 From 2016-12-22 19:45:04 -------
> xfce4-terminal написан на gtk3. Чтобы не делать ползущую миграцию на gtk3,
> пересобирать не будем. Как вариант - патчить старую версию.

Не очень понял. В p8 есть уже два терминала с использованием gtk3:
  gnome-terminal-3.20.3-alt0.M80P.1
    Для установки требует: libvte3 >= 0.44.3
    Требует: <libvte-2.91.so.0()(64bit)>
      libvte3-0.44.3-alt0.M80P.1
  mate-terminal-1.16.1-alt1_1
    Требует: <libvte-2.91.so.0()(64bit)>
      libvte3-0.44.3-alt0.M80P.1

предлагается добавить и третий:
  xfce4-terminal-0.6.90-alt1
    Требует: <libvte-2.91.so.0()(64bit)>
      libvte3-0.44.3-alt0.M80P.1


Ползущую миграцию чего именно не хочется делать?
------- Comment #3 From 2017-01-16 18:04:20 -------
В p8 xfce на gtk2 (исключая один плагин панели). Если в Сизиф я все-таки собрал
новый терминал на gtk3, то я совсем не уверен, что стоит делать это в
стабильном бранче. Скорее уверен, что не стоит. Проблемы со старым vte есть, но
они не настолько критичные, пожалуй, чтобы чтобы оправдать такое изменение.
------- Comment #4 From 2017-01-16 23:56:05 -------
(В ответ на комментарий №3)
> В p8 xfce на gtk2 (исключая один плагин панели).
Какой, кстати?

> Если в Сизиф я все-таки собрал новый терминал на gtk3, то я совсем не уверен,
> что стоит делать это в стабильном бранче. Скорее уверен, что не стоит.
+1
------- Comment #5 From 2017-01-17 01:42:03 -------
(В ответ на комментарий №4)
> (В ответ на комментарий №3)
> > В p8 xfce на gtk2 (исключая один плагин панели).
> Какой, кстати?

xfce4-pulseaudio-plugin
------- Comment #6 From 2017-01-25 20:06:04 -------
(В ответ на комментарий №4)
...
> > Если в Сизиф я все-таки собрал новый терминал на gtk3, то я совсем не уверен,
> > что стоит делать это в стабильном бранче. Скорее уверен, что не стоит.
> +1
По простой причине — вам обоим до лампочки проблемы тех, кто пользуется mc,
потому что с старым vte использование буфера обмена превращается в кошмар.

Для тех, кому всё же нужен нормальный терминал:
# apt-get install eepm
$ epm addrepo etersoft
$ epmI xfc4-terminal
------- Comment #7 From 2017-01-25 21:26:11 -------
(В ответ на комментарий №6)
> По простой причине — вам обоим до лампочки проблемы тех, кто пользуется mc,
> потому что с старым vte использование буфера обмена превращается в кошмар.
Как тебе сказать, Виталик...  Не до лампочки (и у меня в xterm эти
esc-последовательности *порой* тоже вылазят, вообще беда нынче с терминалочным
копипастом и без screen), но mc и впрямь пользуюсь нечасто.

> $ epmI xfc4-terminal
Тут точно все буквы долтели?