Bug 33298 - Не хватает зависимости на libgsf
: Не хватает зависимости на libgsf
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/1c-preinstall)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2017-03-29 13:18 by
Modified: 2017-03-30 10:51 (History)


Attachments
Ошибка при отсутствии libgsf (27.13 KB, image/png)
2017-03-29 13:19, Pavel Isopenko
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-03-29 13:18:53
Если платформа 1С не находит библиотеки libgsf-1.so, она лишается способности
экспортировать табличные документы. Скриншот ошибки во вложении.
Предположительно, для устранения проблемы достаточно добавить в .spec строку
вида Requires: libgsf
Проверено, что если в систему доустановить пакет libgsf - ошибка исчезнет.
Дополнительно: подумать на тему разделения 1с-preinstall на
1с-preinstall-client и 1с-preinstall-server, для оптимизации зависимостей по
режимам запуска платформы.
------- Comment #1 From 2017-03-29 13:19:46 -------
Created an attachment (id=7023) [details]
Ошибка при отсутствии libgsf
------- Comment #2 From 2017-03-29 13:50:48 -------
Причем она была добавлена в 8.3-alt8:
* Tue Mar 18 2014 Andrey Cherepanov <cas at altlinux.org> 8.3-alt8
- Require libgsf for support save to XLS

В 8.3-alt10 было добавлено много зависимостей, а вот libgsf удален.
------- Comment #3 From 2017-03-30 10:51:13 -------
1c-preinstall-8.3-alt11 -> sisyphus:

* Thu Mar 30 2017 Andrey Cherepanov <cas@altlinux> 8.3-alt11
- Return libgsf requirement for support save to XLS (ALT #33298)