Bug 33436 - un-def doesn't boot whereas std-def boots (fails in initrd)
: un-def doesn't boot whereas std-def boots (fails in initrd)
Status: CLOSED DUPLICATE of bug 33277
: Branch p8
(All bugs in Branch p8/kernel-image-un-def)
: не указана
: all Linux
: P3 major
Assigned To:
:
:
:
: 33277
:
  Show dependency tree
 
Reported: 2017-04-30 18:17 by
Modified: 2017-04-30 18:58 (History)


Attachments
screenshot (142.58 KB, image/jpeg)
2017-04-30 18:17, Ivan Zakharyaschev
no flags Details
dmesg from a successful boot of std-def kernel (59.75 KB, text/plain)
2017-04-30 18:19, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-04-30 18:17:58
Created an attachment (id=7080) [details]
screenshot

kernel-image-un-def-4.9.24-alt0.M80P.1
kernel-image-std-def-4.4.63-alt0.M80P.2
kernel-image-std-def-4.4.57-alt0.M80P.2

The un-def kernel doesn't boot (on a Lenovo G50) whereas the std-def kernel
boot successfully. It seems that the failure happens in initrd.

All initrds have been created almost at the same time, with the same
make-initrd:

$ rpm -qa make-initrd\*
make-initrd-lvm-0.8.14-alt1
make-initrd-luks-0.8.14-alt1
make-initrd-devmapper-0.8.14-alt1
make-initrd-0.8.14-alt1

Some interesting lines from the attached "screenshot":

initrd: stage udev failed

The last line is:

clocksource: Switched to clocksource tsc

(the typical one when initrd fails).
------- Comment #1 From 2017-04-30 18:19:36 -------
Created an attachment (id=7081) [details]
dmesg from a successful boot of std-def kernel

Attached: dmesg from a successful boot of std-def kernel
------- Comment #2 From 2017-04-30 18:58:02 -------
Ctrl-D actually can be pressed and the boot continues.

A known workaround: remove FEATURES+=luks line from /etc/initrd.mk

*** This bug has been marked as a duplicate of bug 33277 ***