Bug 33464 - [FR] бэкпортируйте из сизифа arduino, пожалуйста
: [FR] бэкпортируйте из сизифа arduino, пожалуйста
Status: CLOSED FIXED
: Branch p8
(All bugs in Branch p8/arduino)
: не указана
: x86_64 Linux
: P3 enhancement
Assigned To:
:
:
:
:
: 33465
  Show dependency tree
 
Reported: 2017-05-10 23:06 by
Modified: 2017-06-20 08:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-05-10 23:06:06
В Рабочей станции 8.1 все еще arduino 1.0, а в Сизифе 1.6 В этой IDE было много
оптимизаций кода и добавлены новые функции. Бэк портируйте на рабочую станцию.
------- Comment #1 From 2017-05-11 14:47:06 -------
arduino-1:1.6.4-alt1_7.M80P.1jpp8 -> p8:

Wed May 10 2017 Andrey Cherepanov <cas@altlinux.org> 1:1.6.4-alt1_7.M80P.1jpp8
- Backport new version to p8 branch (ALT #32453, #33464)

Fri Dec 16 2016 Igor Vlasenko <viy@altlinux.ru> 1:1.6.4-alt1_8jpp8
- new fc release

Thu Dec 15 2016 Igor Vlasenko <viy@altlinux.ru> 1:1.6.4-alt1_6jpp8
- new version
------- Comment #2 From 2017-05-12 20:53:12 -------
Хм. А тут точно лишних зависимостей не образовалось ?

# apt-get install arduino arduino-core
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
....
3 upgraded, 172 newly installed, 0 removed and 3 not upgraded.
Need to get 62,3MB of archives.

В списке много maven, по чуть-чуть python3 и perl. Или это нормальная разница
между 1.0 и 1.6 ?
------- Comment #3 From 2017-06-19 19:14:23 -------
(In reply to comment #2)
> Хм. А тут точно лишних зависимостей не образовалось ?
> 
> # apt-get install arduino arduino-core
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following extra packages will be installed:
> ....
> 3 upgraded, 172 newly installed, 0 removed and 3 not upgraded.
> Need to get 62,3MB of archives.
> 
> В списке много maven, по чуть-чуть python3 и perl. Или это нормальная разница
> между 1.0 и 1.6 ?

Спасибо за не рабочую версию. Я больше не на альте. Версия поставилась, но не
работала.
------- Comment #4 From 2017-06-20 08:56:26 -------
(In reply to comment #3)

> Спасибо за не рабочую версию. Я больше не на альте. Версия поставилась, но не
> работала.

Вы смените и тот, другой дистрибутив, если одно приложение вызывает его смену.
Стучать ложками тут не в почёте, а вариант поставить рабочий Arduino есть:

https://forum.altlinux.org/index.php?topic=34949.msg311064#msg311064

Специально для стучащих ложками: лучший мантейнер приложения тот, кто им
пользуется. Вы пользуетесь ? Ну так взялись бы за сопровождение.

А текущая версия в p8, действительно, с проблемами: Bug 33501