Bug 33804 - Модуль альтератора для настройки pppoe не отрабатывает без rp-pppoe.so
: Модуль альтератора для настройки pppoe не отрабатывает без rp-pppoe.so
Status: NEW
: Branch p8
(All bugs in Branch p8/alterator-net-pppoe)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2017-08-24 14:03 by
Modified: 2017-08-24 18:31 (History)


Attachments
вывод bash -x для ifup ppp1 (15.22 KB, text/plain)
2017-08-24 18:31, Evgeny Sinelnikov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-08-24 14:03:52
Шаги для воспроизведения с точки зрения пользователя:

1. K->Настройки->Центр управления системой
Сеть->PPPoE-соединения

2. Создать соединение
Состояние -> Запустить

3. Заполняем Логин-пароль, жмакаем "Применить" - пароль исчезает, соединение не
поднимается.


В etcnet для pppoe плагин rp-pppoe.so прописан явно:

$ grep -R rp-pppoe /etc/net -B5 
/etc/net/scripts/create-ppp-    pppoe)
/etc/net/scripts/create-ppp-            [ -n "$HOST" ] || {
/etc/net/scripts/create-ppp-                    print_error "WARNING: HOST is
not set for interface $NAME with PPPTYPE $PPPTYPE"
/etc/net/scripts/create-ppp-                    exit 1
/etc/net/scripts/create-ppp-            }
/etc/net/scripts/create-ppp:            PLUGINOPTION="plugin rp-pppoe.so $HOST"


Плагин rp-pppoe.so лежит в пакете ppp-pppoe

[sin@base ~]$ rpm -ql ppp-pppoe
/usr/lib64/pppd/2.4.7/rp-pppoe.so
/usr/sbin/pppoe-discovery
/usr/share/man/man8/pppoe-discovery.8.gz


При этом пакет alterator-net-pppoe зависит только от rp-pppoe-base

$ rpm -qR alterator-net-pppoe
alterator >= 4.9-alt2
alterator-sh-functions >= 0.3-alt2
alterator-net-functions >= 0.8-alt1
alterator-hw-functions  
rp-pppoe-base  
/bin/sh  
coreutils  
rpmlib(PayloadIsLzma)
------- Comment #1 From 2017-08-24 18:31:37 -------
Created an attachment (id=7196) [details]
вывод bash -x для ifup ppp1