Bug 343 - Не устанавливается.
: Не устанавливается.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libomniORB-devel)
: unstable
: all Linux
: P4 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-01-07 20:00 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-01-07 20:00:27
 sudo apt-get install libomniORB-devel
Извините, но следующие пакеты имеют неудовлетворенные зависимости:
  libomniORB-devel: Depends: python (= 2.1), однако 2.1.1-alt3 будет установлен
Я конечно вручную скопирую, но надо что-то решить к выпуску дистрибутива..
---

---
Stanislav Ievlev wrote
> Увы - это известная проблема apt.  python -2.1.1 provides как версию 2.1 
> так и 2.1.1 (ибо они полностью совместимы), rpm все понимает корректно, 
> а вот apt...
> Я отказываюсь вносить requires python 2.1.1 в libomniORB-devel так как 
> на самом деле достаточно 2.1

------- Comment #1 From 2002-02-12 10:16:47 -------
Все давным давно исправлено. Обновите свой Сизиф.

[<a href="mailto:inger@altair" target="_new">inger@altair</a> RPMS]$ rpm -qp
--requires libomniORB-devel-3.0.4-alt10.i586.rpm 
libomniORB = 3.0.4-alt10
python = 2.2
------- Comment #2 From 2002-02-12 10:16:47 -------
Все давным давно исправлено. Обновите свой Сизиф.

[<a href="mailto:inger@altair" target="_new">inger@altair</a> RPMS]$ rpm -qp
--requires libomniORB-devel-3.0.4-alt10.i586.rpm 
libomniORB = 3.0.4-alt10
python = 2.2