Bug 34300 - новая версия не работает с шифрованными разделами
Summary: новая версия не работает с шифрованными разделами
Status: CLOSED DUPLICATE of bug 34257
Alias: None
Product: Sisyphus
Classification: Development
Component: make-initrd (show other bugs)
Version: unstable
Hardware: all Linux
: P3 normal
Assignee: Alexey Gladkov
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-09 14:56 MSK by alexey.tourbin
Modified: 2017-12-09 18:49 MSK (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexey.tourbin 2017-12-09 14:56:57 MSK
Мужчина Легионус, у меня к вам большая просьба, если вы выкладываете свои новые поделия в Сизифус, то хотя бы пожалуйста тестируйте их на машине с зашифрованными разделами.  Потому что ну вот я обновился, у меня отвалился диск, машина не грузится.  Какие чувства я должен испытывать к вашим разработческим талантам?

Несколько точнее, обновление make-initrd с 2.0.4 до 2.0.5 приводит к тому, что ядро не загружается. Откат до 2.0.4 (sudo rpm -Uv --oldpackage make-initrd*_2.0.4* в каталоге /var/cache/apt/archives) восстанавливает работоспособность более или менее.
Comment 1 Alexey Gladkov 2017-12-09 18:49:14 MSK
> Мужчина Легионус, у меня к вам большая просьба, если вы выкладываете свои новые
> поделия в Сизифус

Сизиф это не стабильный дистрибутив и в нём случаются поломки. Если вы с этим не согласны, то идите в "стабильные" бранчи или же вы можете не пользоваться моими поделиями и использовать mkinitrd. Я никого силой не заставляю.

> то хотя бы пожалуйста тестируйте их на машине с
> зашифрованными разделами.  Потому что ну вот я обновился, у меня отвалился
> диск, машина не грузится.  Какие чувства я должен испытывать к вашим
> разработческим талантам?

Я не сумею передать насколько мне безразлично то, что вы там испытываете к моим талантам.

> Несколько точнее, обновление make-initrd с 2.0.4 до 2.0.5 приводит к тому, что
> ядро не загружается. Откат до 2.0.4 (sudo rpm -Uv --oldpackage
> make-initrd*_2.0.4* в каталоге /var/cache/apt/archives) восстанавливает
> работоспособность более или менее.

Если вы используете luks с паролем, то это же исправлено в версии 2.0.6-alt1, которая уже в сизифе.

*** This bug has been marked as a duplicate of bug 34257 ***