Bug 34508 - При обновлении с p8 до Sisyphus конфликт с lua
: При обновлении с p8 до Sisyphus конфликт с lua
Status: CLOSED DUPLICATE of bug 33095
: Sisyphus
(All bugs in Sisyphus/lua5)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 34319
  Show dependency tree
 
Reported: 2018-02-05 10:07 by
Modified: 2018-02-07 02:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2018-02-05 10:07:05
В багах #34319 и #34505 описана суть, для обновления до Sisyph'a необходимо
сначала обновить rpm и apt. После обновления  apt и rpm делаю dist-upgrade, он
выдает ошибку:
...
1038 будет обновлено, 163 новых установлено, 7 пакетов будет заменено, 8
пакетов будет удалено и 5 не будет обновлено.
Необходимо получить 0B/954MB архивов.
После распаковки потребуется дополнительно 458MB дискового пространства.
Продолжить? [Y/n] 
Совершаем изменения...  
Подготовка...                                     
####################################################################################################
[100%]
        файл /usr/lib64/lua/5.1 из устанавливаемого пакета
liblua5.1-5.1.5-alt14.x86_64 конфликтует с файлом из пакета
lua5.1-alt-compat-1.0-alt1.x86_64
        файл /usr/share/lua/5.1 из устанавливаемого пакета
liblua5.1-5.1.5-alt14.x86_64 конфликтует с файлом из пакета
lua5.1-alt-compat-1.0-alt1.x86_64
E: Ошибка во время исполнения транзакции



Помогает при обновлении apt удалить конфликтующие пакеты:
# apt-get install apt rpm lua5.3 liblua5.1- lua5.1-alt-compat-
liblua5.1-preinstall- lua-module-luasocket
------- Comment #1 From 2018-02-07 02:29:40 -------
Дубликат.

*** This bug has been marked as a duplicate of bug 33095 ***