Bug 34858 - конфликт при установке kde5-pim-runtime
: конфликт при установке kde5-pim-runtime
Status: CLOSED DUPLICATE of bug 35492
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2018-04-27 11:32 by
Modified: 2018-10-23 13:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2018-04-27 11:32:34
Добрый всем день!
Вот столкнулся на текущем сизифе:
Что посоветуете?
система i586 32bit


apt> install kde5-knotes

Следующие НОВЫЕ пакеты будут установлены:
  kde5-akonadi kde5-akonadi-calendar-common kde5-akonadi-database-8-mysql
kde5-akonadi-mime-common kde5-akonadi-notes-common kde5-akonadi-search
kde5-akonadi-search-commo
  kde5-kalarmcal-common kde5-kcalutils-common kde5-kdav-common
kde5-kimap-common kde5-kldap-common kde5-kmailtransport-common
kde5-kmbox-common kde5-knotes kde5-knotes-co
  kde5-kontactinterface-common kde5-ksmtp-common kde5-libkdepim-common
kde5-libkgapi-common kde5-pim-runtime kde5-pim-runtime-common
kde5-pimcommon-common libakonadi-file
  libakonadi-singlefileresource5 libfolderarchivesettings5
libkf5akonadiagentbase libkf5akonadicalendar libkf5akonadimime
libkf5akonadinotes libkf5akonadisearchcore
  libkf5akonadisearchdebug libkf5akonadisearchpim libkf5akonadisearchxapian
libkf5akonadixml libkf5alarmcalendar libkf5calendarutils libkf5imap
libkf5kontactinterface lib
  libkf5libkdepim5 libkf5libkdepimakonadi5 libkf5mailtransport
libkf5mailtransportakonadi libkf5mbox libkf5pimcommon5 libkf5pimcommonakonadi5
libkmindexreader5 libknotesp
  libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5 libkpimgapitasks5
libkpimkdav5 libkpimsmtp5 libmaildir5 libnotesharedprivate5 qt5-sql-mysql
0 будет обновлено, 58 новых установлено, 0 пакетов будет удалено и 1 не будет
обновлено.
Необходимо получить 0B/8056kB архивов.
После распаковки потребуется дополнительно 35,1MB дискового пространства.
Продолжить? [Y/n]
Совершаем изменения...
Подготовка...
########################################################################################
        конфликт файла /usr/lib/sasl2/libkdexoauth2.so при попытках установки
kde5-pim-runtime-17.12.3-alt1.S1.i586 и kde5-pim-runtime-17.12.3-alt1.S1.i586
        конфликт файла /usr/lib/sasl2/libkdexoauth2.so.3 при попытках установки
kde5-pim-runtime-17.12.3-alt1.S1.i586 и kde5-pim-runtime-17.12.3-alt1.S1.i586
        конфликт файла /usr/lib/sasl2/libkdexoauth2.so.3.0.0 при попытках
установки kde5-pim-runtime-17.12.3-alt1.S1.i586 и
kde5-pim-runtime-17.12.3-alt1.S1.i586
E: Ошибка во время исполнения транзакции
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Handler silently failed
apt>

--------------------------------
Не помогло решить проблему:
apt-get dist-upgrade
apt-get install kde5-pim-runtime
rpm --rebuilddb
удаление кэш apt: /var/cache/apt/*.bin
------- Comment #1 From 2018-04-27 11:38:54 -------
конфликт сам с собой ? это как ?
------- Comment #2 From 2018-04-27 11:41:55 -------
(В ответ на комментарий №1)
> конфликт сам с собой ? это как ?
Было уже. Видимо, на i586 еще осталось.
------- Comment #3 From 2018-04-27 11:43:20 -------
(В ответ на комментарий №0)
> 1 не будет обновлено.
Интересно, это кто? dist-upgrade должен говорить, кто.
------- Comment #4 From 2018-10-22 18:33:16 -------
Интересно, это из той же серии? apt-0.5.15lorg2-alt58.x86_64, сегодняшняя
попытка обновить (apt-get install gdb):

file /usr/share/gdb/python/gdb from install of gdb-8.2.50.20180917-alt1.x86_64
conflicts with file from package gdb-7.9-alt4.x86_64

На всякий случай rpm обновил (до rpm-4.13.0.1-alt2).
------- Comment #5 From 2018-10-23 10:23:45 -------
https://lists.altlinux.org/pipermail/devel/2018-October/205585.html

*** This bug has been marked as a duplicate of bug 35492 ***
------- Comment #6 From 2018-10-23 10:44:47 -------
(In reply to comment #5)

> https://lists.altlinux.org/pipermail/devel/2018-October/205585.html
> 
> *** This bug has been marked as a duplicate of bug 35492 ***

Так, всё же, это apt виновник, или конкретный пакет в каждом случае?
------- Comment #7 From 2018-10-23 11:05:10 -------
(В ответ на комментарий №6)
> apt виновник
Да
------- Comment #8 From 2018-10-23 11:08:19 -------
(In reply to comment #4)
> Интересно, это из той же серии? apt-0.5.15lorg2-alt58.x86_64, сегодняшняя
> попытка обновить (apt-get install gdb):
> 
> file /usr/share/gdb/python/gdb from install of gdb-8.2.50.20180917-alt1.x86_64
> conflicts with file from package gdb-7.9-alt4.x86_64
> 
> На всякий случай rpm обновил (до rpm-4.13.0.1-alt2).

Нет, с gdb совсем другая история.
------- Comment #9 From 2018-10-23 13:11:54 -------
(In reply to comment #8)

> Нет, с gdb совсем другая история.

То есть, ошибку с gdb надо оставить на gdb, а эту вернуть на apt? И я, тогда,
зря написал тут Comment #4?