Bug 3525 - 3.0-alt0.12 не может открыть проект на C++ созданный 3.0-alt0.11
: 3.0-alt0.12 не может открыть проект на C++ созданный 3.0-alt0.11
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kdevelop)
: unstable
: all Linux
: P4 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-01-20 14:32 by
Modified: 2008-03-11 16:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-01-20 14:32:42
при попытке открытия проекта вылезает окошко "Could not create language plugin 
for C++" 
удаление ~/.kde/share/config/kdeveloprc не помогает.
------- Comment #1 From 2004-01-25 12:27:54 -------
Обнаружил: 
- с новым C++ проектом всё работает (simple KDE app) 
- kdevelop из Sisyphus и kdevelop из KDE CVS HEAD линкуются примерно к одним 
библиотекам, т.е. в hasher ничего не потерялось 
 
Таким образом, советую пересоздать проект мастером, из исходников. 
Возможно, следующая версия будет вести себя корректней, но ещё когда она 
появится в Сизифе. 
 
Если вы понимаете по-немецки, можете почитать здесь: 
http://www.gnulinux.de/modules.php?name=4nForum&file=viewthread&tid=419 
 
Также возможно, что у вас отсутствует какой-либо -devel пакет. libstdc++-devel, 
например. Указать все такие пакеты в зависимостях KDevelop было бы некорректно, 
так как не все пишут на C++. 
 
Если вас не затруднит, держите меня в курсе. 
------- Comment #2 From 2004-01-26 21:46:11 -------
strace говорит, что непосредственно после чтения файла проекта (.kdevelop) 
kdevelop пытается найти libkdevcppsupport.la, который отсутствует. 
libkdevcppsupport.so искать не даже пытается... 
------- Comment #3 From 2004-01-28 13:51:28 -------
kdelibs-3.1.4-alt4  -  ещё с .la 
У KDevelop 3.0-alt0.12 крыша едет. 
 
Решение: обновить kdelibs до Sisyphus. 
 
В новой сборке поставлю условие на версию kdelibs. 
------- Comment #4 From 2008-02-15 23:00:15 -------
Подозреваю, что всё уже работает.
------- Comment #5 From 2008-03-11 15:25:34 -------
(In reply to comment #4)
> Подозреваю, что всё уже работает.

Давайте спросим у мэйнтейнера? 8)
------- Comment #6 From 2008-03-11 16:16:26 -------
В kdevelop-for-kde стоят необходимые зависимости для вытаскивания 
libkdevcppsupport.la