Bug 3544 - incomplete info-install dependency
: incomplete info-install dependency
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/glibc-devel)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-01-26 14:24 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-01-26 14:24:59
Если обновляться с M2.2 до Sisyphus января 2004, то rpm спотыкается на
glibc-devel .
Он требует /usr/sbin/(un)install_info, который содержится в сизифовском
info-install, но не в мастеровском.
22: glibc-devel             
###########################################################################################
[100%]
/root/tmp/rpm-tmp.47736: line 1: /usr/sbin/install_info: No such file or
directory
error: execution of %post scriptlet from glibc-devel-2.2.6-alt0.11 failed, exit
status 127
-------------------
# apt-get remove glibc-devel
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  glibc-devel
0 upgraded, 0 newly installed, 1 removed and 124 not upgraded.
Need to get 0B of archives.
After unpacking 2583kB disk space will be freed.
Do you want to continue? [Y/n]
Committing changes...
Preparing...                
###########################################################################################
[100%]
/root/tmp/rpm-tmp.77257: line 1: /usr/sbin/uninstall_info: No such file or
directory
error: execution of %preun scriptlet from glibc-devel-2.2.6-alt0.11 failed,
exit
status 127
-----------------------
Мне кажется, зависимость в glibc-devel нужно вешать на подходящую версию
info-install.
------- Comment #1 From 2004-02-04 00:02:47 -------
Да, нужно обновить зависимость, но из-за этого я пересобирать glibc-devel не
стану. 
------- Comment #2 From 2004-02-07 16:38:44 -------
Я и не предлагаю пересобирать прямо сейчас. Просто учтите при случае.
------- Comment #3 From 2004-03-26 20:52:15 -------
Fixed in 2.2.6-alt0.12