Bug 35579 - Некорректно установлена зависимость ntp от ntpd
: Некорректно установлена зависимость ntp от ntpd
Status: CLOSED DUPLICATE of bug 35580
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: https://lists.altlinux.org/pipermail/...
:
:
:
  Show dependency tree
 
Reported: 2018-11-06 16:01 by
Modified: 2018-11-07 05:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2018-11-06 16:01:14
$ sudo apt-get install ntp
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  ntp: Требует: .sisyphus.213754.100.1.1-ntpd-4.2.8p12-alt1
E: Извините, `битые' пакеты

После установки ntpd проблема уходит, ntp ставится без проблем.

$ sudo apt-get install ntpd
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие пакеты будут УДАЛЕНЫ:
  openntpd
Следующие НОВЫЕ пакеты будут установлены:
  ntpd
0 будет обновлено, 1 новых установлено, 1 пакетов будет удалено и 0 не
будет обновлено.
Необходимо получить 354kB архивов.
После распаковки потребуется дополнительно 762kB дискового пространства.
Продолжить? [Y/n]
Получено: 1 http://ftp.altlinux.org Sisyphus/x86_64/classic ntpd
4.2.8p12-alt1 [354kB]
Получено 354kB за 1s (278kB/s).
Совершаем изменения...
Подготовка...

############################################################################################
[100%]
Обновление / установка...
1: ntpd-4.2.8p12-alt1

############################################################################################
[ 50%]
Очистка / удаление...
2: openntpd-3.9p1-alt13

############################################################################################
[100%]
 Завершено.
$ sudo apt-get install ntp
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  ntp-doc
Следующие НОВЫЕ пакеты будут установлены:
  ntp ntp-doc
0 будет обновлено, 2 новых установлено, 0 пакетов будет удалено и 0 не
будет обновлено.
Необходимо получить 1298kB архивов.
После распаковки потребуется дополнительно 2687kB дискового пространства.
Продолжить? [Y/n]
Получено: 1 http://ftp.altlinux.org Sisyphus/noarch/classic ntp-doc
4.2.8p12-alt1 [1288kB]
Получено: 2 http://ftp.altlinux.org Sisyphus/x86_64/classic ntp
4.2.8p12-alt1 [10,3kB]
Получено 1298kB за 1s (651kB/s).
Совершаем изменения...
Подготовка...

############################################################################################
[100%]
Обновление / установка...
1: ntp-doc-4.2.8p12-alt1
############################################################################################
[ 50%]
2: ntp-4.2.8p12-alt1
############################################################################################
[100%]
Завершено.
------- Comment #1 From 2018-11-06 16:38:24 -------
Врятли тут ntp виноват, т.к. ntpd провайдит нужное:
.sisyphus.213754.100.1.1-ntpd-4.2.8p12-alt1
------- Comment #2 From 2018-11-06 21:15:14 -------
(In reply to comment #1)

> Врятли тут ntp виноват, т.к. ntpd провайдит нужное:
> .sisyphus.213754.100.1.1-ntpd-4.2.8p12-alt1

Да, в метапакете ntp есть "Requires: ntpd = %version-%release".
------- Comment #3 From 2018-11-07 05:03:11 -------
.

*** This bug has been marked as a duplicate of bug 35580 ***