Bug 35626 - Неудовлетворенные зависимости
: Неудовлетворенные зависимости
Status: NEW
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 minor
Assigned To:
:
:
:
:
: 35195 35625
  Show dependency tree
 
Reported: 2018-11-20 20:48 by
Modified: 2018-11-21 08:23 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2018-11-20 20:48:49
Как это происходит в apt --
https://bugzilla.altlinux.org/show_bug.cgi?id=35195#c3 :

$ hsh --ini --apt-config=/home/imz/.hasher/p8/apt.conf --without-stuff
~/hasher/
$ ~/hasher/aptbox/apt-get install emacs24-X11
...
MI2c: mark emacs24-X11
MI2c:  target emacs-X11-program
MI2c:   mark emacs25-X11-motif
MI2c:    target emacs25-X11
MI2c:     mark emacs25-X11
MI2c:      target emacs25-common
MI2c:       mark emacs25-common
MI2c:        target emacs-speedbar AMB
MI2c:        target emacs-tramp AMB
MI2c:        target emacs25-gnus
MI2c:         mark emacs25-gnus
MI2c:          delete emacs24-gnus
MI2c:        delete emacs24-common
MI2c:      delete emacs24-X11
...

Т.е. алгоритм поиска решения apt несовершенен. Подумал бы ещё, нашёл бы
решение.

+++ This bug was initially created as a clone of Bug #35625 +++

Всё то же самое:

$ rpm -qp /ALT/Sisyphus/x86_64/RPMS.classic/emacs26-common-26.1-alt1.x86_64.rpm
 --provides
/usr/lib/emacs
emacs-common = 26.1-alt1

Убрать:

emacs21-common = 26.1-alt1
emacs22-common = 26.1-alt1
emacs23-common = 26.1-alt1
emacs24-common = 26.1-alt1
emacs25-common = 26.1-alt1

emacs-ses = 26.1-alt1
emacs-url = 26.1-alt1
pkgconfig(emacs) = 2.0
emacs26-common = 26.1-alt1
$ rpm -qp /ALT/Sisyphus/noarch/RPMS.classic/emacs26-X11-26.1-alt1.noarch.rpm
--requires
emacs26-common = 26.1-alt1

Уточнить (с номером):

emacs-X11-program
rpmlib(PayloadIsLzma)
$ rpm -qp /ALT/Sisyphus/x86_64/RPMS.classic/emacs26-common-26.1-alt1.x86_64.rpm
--obsoletes
emacs26

Зачем? Не нужно. Противоречит идее дать людям иметь несколько версий emacs,
ради кторой и добавили в имя номер версии:

emacs-common
emacs21-common
emacs22-common
emacs23-common
emacs24-common
emacs25-common
emacs-ses <= 1.0-alt2.031130
-bash-4.3$ 


+++ This bug was initially created as a clone of Bug #35195 +++

При выполнении
# apt-get install emacs24-X11
получаю
Следующие пакеты имеют неудовлетворенные зависимости:
  emacs24-X11: Для установки требует: emacs24-common (= 24.5-alt16)
E: Извините, `битые' пакеты

Если emacs24-common установить "вручную", emacs24-X11 (и *-gtk3, который мне и
был нужен) устанавливается.
PS. Графический интерфейс установки пакетов вообще зависает из-за такой
ситуации.
------- Comment #1 From 2018-11-21 08:23:24 -------
Похоже на дубль https://bugzilla.altlinux.org/show_bug.cgi?id=35580