Bug 3888 - requires bug: requires guile16 but not work with it
: requires bug: requires guile16 but not work with it
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/gnucash)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-03-26 20:43 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-03-26 20:43:59
hmepas@localhost ~ $ rpm -qi --requires gnucash | grep guile
guile16 >= 1.6
slib-guile  
guile16  
hmepas@localhost ~ $ rpm -qa | grep quile
hmepas@localhost ~ $ rpm -qa | grep guile
slib-guile-2d6-alt1
guile16-devel-1.6.4-alt4
guile16-1.6.4-alt4
hmepas@localhost ~ $ gnucash
/usr/lib/gnucash/overrides/guile: line 8: /usr/bin/guile: No such file or directory
/usr/lib/gnucash/overrides/guile: line 8: exec: /usr/bin/guile: cannot execute:
No such file or directory

Workaround:
$ sudo ln -s /usr/bin/guile16 /usr/bin/guile 
$ gnucash    

But may be this is guile16 package bug
------- Comment #1 From 2004-03-27 15:20:34 -------
Это проблема может относиться только к guile. 
Вообще при установке guile16 нужная альтернатива устанавливается. 
Что у вас с 
# rpm -qa | grep alternatives 
 
------- Comment #2 From 2004-03-27 15:39:55 -------
$ rpm -qa | grep alternatives 
update-alternatives-1.8.3-alt1
alternatives-0.1.0-alt1
libalternatives-0.1.0-alt1
------- Comment #3 From 2004-04-06 22:43:15 -------
Some problem with alternatives in your system? 
------- Comment #4 From 2004-04-06 23:47:50 -------
Очень может быть. Если я такой единственный багу можно закрывать.