Bug 396 - fail to upgrade XFree86-cyr_rfx-fonts-koi8-r with apt-get
: fail to upgrade XFree86-cyr_rfx-fonts-koi8-r with apt-get
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/XFree86-cyr_rfx-fonts-koi8-1)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-01-16 02:31 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-01-16 02:31:15
<a href="mailto:root@israfel" target="_new">root@israfel</a> ~ # rpm -q
XFree86-cyr_rfx-fonts-koi8-1
XFree86-cyr_rfx-fonts-koi8-1-1.1-ipl3mdk

<a href="mailto:root@israfel" target="_new">root@israfel</a> ~ # apt-get -o
Debug::pkgProblemResolver=true install XFree86-cyr_rfx-fonts-koi8-1
Processing File Dependencies... Done
Reading Package Lists... Done       
Building Dependency Tree... Done
Starting
Starting 2
Package XFree86-cyr_rfx-fonts-koi8-r has broken dep on
XFree86-cyr_rfx-fonts-koi8-1
  Considering XFree86-cyr_rfx-fonts-koi8-1 10002 as a solution to
XFree86-cyr_rfx-fonts-koi8-r 6
  Holding Back XFree86-cyr_rfx-fonts-koi8-r rather than change
XFree86-cyr_rfx-fonts-koi8-1
Package XFree86-cyr_rfx-fonts-koi8-1 has broken dep on
XFree86-cyr_rfx-fonts-koi8-r
  Considering XFree86-cyr_rfx-fonts-koi8-r 6 as a solution to
XFree86-cyr_rfx-fonts-koi8-1 10002
    Reinst Failed because of protected XFree86-cyr_rfx-fonts-koi8-1
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  XFree86-cyr_rfx-fonts-koi8-1: Depends: XFree86-cyr_rfx-fonts-koi8-r but it is
not going to be installed
E: Sorry, broken packages

---

---
------- Comment #1 From 2002-01-16 10:12:24 -------
The XFree86-cyr_rfx-fonts-koi8-1 is obsoleted by XFree86-cyr_rfx-fonts-koi8-r
package. Current XFree86-cyr_rfx-fonts-koi8-1 in Sisyphus is not a font package
but a package renaming helper. In order to replace packages, just run
\&quot;apt-get dist-upgrade\&quot;, or remove and install them manually.
------- Comment #2 From 2002-01-16 10:12:24 -------
The XFree86-cyr_rfx-fonts-koi8-1 is obsoleted by XFree86-cyr_rfx-fonts-koi8-r
package. Current XFree86-cyr_rfx-fonts-koi8-1 in Sisyphus is not a font package
but a package renaming helper. In order to replace packages, just run
\&quot;apt-get dist-upgrade\&quot;, or remove and install them manually.