Bug 4012 - при установке через apt не вытаскивается libnessus-devel
: при установке через apt не вытаскивается libnessus-devel
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/nessus-plugins)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-04-22 13:01 by
Modified: 2005-07-31 06:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-04-22 13:01:08
[root@eof root]# apt-get install libnessus nessus-client nessus-server
nessus-plugins
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libgd2 libnasl libnet2 libpcap
The following packages will be REMOVED:
  libpcap0.8 nmap nmap-frontend tcpdump
The following NEW packages will be installed:
  libgd2 libnasl libnessus libnet2 libpcap nessus-client nessus-plugins
nessus-server
0 upgraded, 8 newly installed, 4 removed and 7 not upgraded.
Need to get 2453kB of archives.
After unpacking 5827kB of additional disk space will be used.
Do you want to continue? [Y/n]

При установке через apt не вытаскивается libnessus-devel, что делает невозможным
загрузку плагинов. В документации необходимость libnessus-devel для нормальной
работы не отражена никак, вычислить эту зависимость можно только
экспериментальным путем.
------- Comment #1 From 2004-06-04 18:28:07 -------
priority +1 для профилактики. 
Скорее всего причина в том что плагины грузятся по имени .so, которые 
ошибочно попадают в devel подпакет. 
 
------- Comment #2 From 2004-06-04 20:09:56 -------
Я уже давно к этому пакету не имею никакого отношения
------- Comment #3 From 2004-06-22 05:14:17 -------
У меня не воспроизводится. 

$ rpm -qa|grep nessus
nessus-server-2.0.10-alt1
nessus-plugins-2.0.10-alt1
nessus-client-2.0.10-alt1
libnessus-2.0.10-alt1

Похожая проблема встречалась у кого-то в community@. Проблема решалась чисткой
системы (оставались какие-то библиотеки от установки Nessus'а из tar-ball'ов).