Bug 41117 - Файловые конфликты с пакетом apache2-htpasswd
Summary: Файловые конфликты с пакетом apache2-htpasswd
Status: RESOLVED WORKSFORME
Alias: None
Product: Branch p9
Classification: Distributions
Component: mini_httpd-htpasswd (show other bugs)
Version: не указана
Hardware: x86_64 Linux
: P5 normal
Assignee: qa-team@altlinux.org
QA Contact: qa-p9@altlinux.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-13 12:53 MSK by Mikhail Chernonog
Modified: 2023-01-31 16:46 MSK (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Chernonog 2021-10-13 12:53:03 MSK
# apt-get install mini_httpd-htpasswd
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  mini_httpd-htpasswd
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B/7232B архивов.
После распаковки потребуется дополнительно 13,6kB дискового пространства.
Совершаем изменения...  
Подготовка...                                      #################################################################################################### [100%]
        файл /usr/bin/htpasswd из устанавливаемого пакета mini_httpd-htpasswd-1.19-alt2.1.x86_64 конфликтует с файлом из пакета apache2-htpasswd-1:2.4.48-alt3.x86_64
        файл /usr/share/man/man1/htpasswd.1.xz из устанавливаемого пакета mini_httpd-htpasswd-1.19-alt2.1.x86_64 конфликтует с файлом из пакета apache2-htpasswd-1:2.4.48-alt3.x86_64
E: Ошибка во время исполнения транзакции

Было сделано исправления для Sisyphus в задаче #39048
Пожалуйста отправьте новую версию пакета в репозиторий p9.
Comment 1 Ivan Alekseev 2023-01-31 16:46:09 MSK
По указанным шагам ошибка не воспроизвелась.

Стенд: p9-kworkstation-9.2-x86-64

Версии пакетов:
apache2-htpasswd-1:2.4.53-alt1
mini_httpd-htpasswd-1.30-alt1

[root@kworkstation-9-20230131 ~]# apt-get install apache2-htpasswd
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libapr1 libaprutil1
Следующие НОВЫЕ пакеты будут установлены:
  apache2-htpasswd libapr1 libaprutil1
0 будет обновлено, 3 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B/237kB архивов.
После распаковки потребуется дополнительно 480kB дискового пространства.
Продолжить? [Y/n] 
Совершаем изменения...  
Подготовка...                           ########################################################## [100%]
Обновление / установка...
1: libapr1-1.6.5-alt1                   ########################################################## [ 33%]
2: libaprutil1-1.6.1-alt2               ########################################################## [ 67%]
3: apache2-htpasswd-1:2.4.53-alt1       ########################################################## [100%]
Завершено.

[root@kworkstation-9-20230131 ~]# apt-get install mini_httpd-htpasswd
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  mini_httpd-htpasswd
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B/8490B архивов.
После распаковки потребуется дополнительно 17,7kB дискового пространства.
Совершаем изменения...  
Подготовка...                           ########################################################## [100%]
Обновление / установка...
1: mini_httpd-htpasswd-1.30-alt1        ########################################################## [100%]
Завершено.