Bug 42586 - ошибка компиляции
Summary: ошибка компиляции
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: arduino (show other bugs)
Version: unstable
Hardware: x86_64 Linux
: P5 normal
Assignee: viy
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-26 08:29 MSK by Anton Shevtsov
Modified: 2023-01-16 14:22 MSK (History)
4 users (show)

See Also:


Attachments
arduino ide error (86.67 KB, image/png)
2022-04-26 08:29 MSK, Anton Shevtsov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Shevtsov 2022-04-26 08:29:01 MSK
Created attachment 10659 [details]
arduino ide error

АльтОбразование 10.
Arduino из репо. Тот код, который на экране, дефолтный шаблон.
Запуск - Скетч/проверить-компилировать - порождает сообщение об ошибке

Более новая версия с сайта, лишена такого сообщения  

Также, пункты меню "помощь" почти все ведут в никуда
Comment 1 viy 2022-04-26 13:33:59 MSK
Доберусь не раньше середины мая, приветствуется, если кто раньше сможет помочь чем-то, к примеру, патчами или сборкой исправления.
Comment 2 Norbert X 2022-07-07 22:15:57 MSK
Проблема существует в p10 (1.8.13-alt1_5jpp11), Sisyphus (1.8.13-alt2_5jpp11).
В текстовом виде выглядит так:

```
Parameter 'tools' is mandatory
Usage of /usr/bin/arduino-builder:
  -build-cache string
    	builds of 'core.a' are saved into this folder to be cached and reused
  -build-options-file string
    	Instead of specifying --hardware, --tools etc every time, you can load all such options from a file
  -build-path string
    	build path
  -built-in-libraries value
    	Specify a built-in 'libraries' folder. These are low priority libraries. Can be added multiple times for specifying multiple built-in 'libraries' folders
  -compile
    	compiles the given sketch
  -core-api-version string
    	version of core APIs (used to populate ARDUINO #define) (default "10600")
  -debug-level int
    	Turns on debugging messages. The higher, the chattier (default 5)
  -dump-prefs
    	dumps build properties used when compiling
  -fqbn string
    	fully qualified board name
  -hardware value
    	Specify a 'hardware' folder. Can be added multiple times for specifying multiple 'hardware' folders
  -ide-version string
    	[deprecated] use 'core-api-version' instead (default "10600")
  -libraries value
    	Specify a 'libraries' folder. Can be added multiple times for specifying multiple 'libraries' folders
  -logger string
    	Sets type of logger. Available values are 'human', 'machine' (default "human")
  -prefs value
    	Specify a custom preference. Can be added multiple times for specifying multiple custom preferences
  -preprocess
    	preprocess the given sketch
  -quiet
    	if 'true' doesn't print any warnings or progress or whatever
  -tools value
    	Specify a 'tools' folder. Can be added multiple times for specifying multiple 'tools' folders
  -verbose
    	if 'true' prints lots of stuff
  -version
    	prints version and exits
  -vid-pid string
    	specify to use vid/pid specific build properties, as defined in boards.txt
  -warnings string
    	Sets warnings level. Available values are 'none', 'default', 'more' and 'all'

Error compiling for board Arduino Uno.
```

Т.е., похоже, что где-то прописана ошибочная команда на компиляцию.

Версия из p9 (1.8.5-alt2_8jpp8) и из Flatpak ошибке не подвержены.

Пожалуйста, почините, нужный для образования пакет Arduino в p10.
Comment 3 viy 2022-07-08 12:30:17 MSK
Устанавливайте, пожалуйста, arduino из их сайта.
С поддержкой arduino сейчас проблемы.
Comment 4 ctpanic 2022-12-25 13:21:15 MSK
Проблема присутствует в свежеустановленном (и обновлённом) Simply 10.1

Решил так: sudo mkdir /usr/share/arduino/tools-builder

(совет с  https://arduino.stackexchange.com/questions/47182/arduino-ide-fails-on-fedora-with-arduino-builder-error-parameter-tools-is-man)
Comment 5 ctpanic 2022-12-25 14:13:16 MSK
(не могу изменить свой комментарий, поэтому пишу новый)

Извиняюсь, поторопислся. На самом деле срабатывают два совета из ссылки в предыдущем посте. 
Кроме создания (то рута) /usr/share/arduino/tools-builder, также помогло создание ~/.arduino15/packages - в этом случае права рута не нужны
Comment 6 Norbert X 2022-12-25 14:43:48 MSK
Действительно, работает.

Получается что ошибка может быть исправлена включением пустого каталога /usr/share/arduino/tools-builder в rpm-пакет.
Comment 7 gubina@basealt.ru 2023-01-12 17:59:32 MSK
Коллеги, баг на месте, компиляция не работает. Можно ускорить решение проблемы?
Comment 8 Repository Robot 2023-01-16 14:22:26 MSK
arduino-1:1.8.13-alt3_5jpp11 -> sisyphus:

 Mon Jan 16 2023 Andrey Cherepanov <cas@altlinux> 1:1.8.13-alt3_5jpp11
 - created empty directory to prevent compiler error (ALT #42586).