Bug 42934 - Не работает опция build-dep
Summary: Не работает опция build-dep
Status: NEW
Alias: None
Product: Sisyphus
Classification: Development
Component: apt (show other bugs)
Version: unstable
Hardware: x86_64 Linux
: P5 normal
Assignee: Gleb F-Malinovskiy
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-04 06:03 MSK by ruslandh
Modified: 2022-08-11 07:05 MSK (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ruslandh 2022-06-04 06:03:41 MSK
# apt-get build-dep stacer-1.1.0-alt1.3.src.rpm 
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: зависимость Build-Depends для stacer-1.1.0-alt1.3.src.rpm не может быть удовлетворена, потому что отсутствует пакет rpmlib(PayloadIsLzma).
Comment 1 Norbert X 2022-07-10 19:38:54 MSK
Тоже столкнулся с этой проблемой на p10, подробно описал в https://forum.altlinux.org/index.php?topic=46391.0 .

Краткая суть в моем случае:

```
$ eepm rl
/etc/apt/sources.list.d/yandex.list:
    rpm [p10] http://mirror.yandex.ru altlinux/p10/branch/x86_64 classic
    rpm [p10] http://mirror.yandex.ru altlinux/p10/branch/x86_64-i586 classic
    rpm [p10] http://mirror.yandex.ru altlinux/p10/branch/noarch classic
    rpm-src [p10] http://mirror.yandex.ru altlinux/p10/branch/x86_64 classic
    rpm-src [p10] http://mirror.yandex.ru altlinux/p10/branch/noarch classic

$ sudo apt-get build-dep -y htop
Reading Package Lists... Done
Building Dependency Tree... Done
E: Build-Depends dependency for htop-3.0.5-alt1.src.rpm cannot be satisfied because the package rpmlib(PayloadIsLzma) cannot be found
```
Comment 2 Vitaly Lipatov 2022-08-11 01:13:01 MSK
А это точно нужно?
Я делаю так:
$ rpmgp -i
в репозитории с пакетом.
Comment 3 ruslandh 2022-08-11 07:05:39 MSK
Интересный вариант.  Возикает несколько вопросов сразу ;-) :
1. А для новых пакетов, которых ещё нет в репозитоии это подойдёт ? 
2. А epm не поставит случайно пакеты (пересобрав), если зависимого пакета ещё нет в репозитории ?

Ну и формально - наличие альтернативного пакета, не отменяет недостатки первого пакета ;-)

PS Но как временная замена  
rpmgp -i
подходящий вариант, спасибо. Надо на Wiki отразить такой вариант ;-)