Bug 4337 - USB hotplug support required
: USB hotplug support required
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sane)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
: 3459
  Show dependency tree
 
Reported: 2004-06-10 14:49 by
Modified: 2006-12-17 16:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-06-10 14:49:57
Драйвер scanner, обеспечивающий доступ к USB-сканерам через /dev/usb/scanner*,
исчез из ядер 2.6.x, да и в 2.4.x считается устаревшим. Большинство backend-ов,
работающих с USB-устройствами, использует для доступа к ним libusb. Однако для
такого доступа необходимо назначение прав на соответствующие файлы в
/proc/bus/usb, что делается через hotplug.

В sane-backends-1.0.14/tools/hotplug уже лежат необходимые файлы - нужно только
положить их в соответствующие каталоги.
------- Comment #1 From 2004-06-24 01:01:00 -------
fixed in sane-1.0.14-alt2 
------- Comment #2 From 2004-07-14 12:32:34 -------
Сейчас скрипт есть, но всё равно не работает, поскольку выполняет chown
root:scanner "$DEVICE", а группы scanner нет.  Необходимо создавать эту группу
при установке пакета.
------- Comment #3 From 2004-09-08 10:27:32 -------
fixed in sane-1.0.14-alt4