Bug 4340 - Doesn't work with xmms-out-crossfade & arts >= 1.2.2
: Doesn't work with xmms-out-crossfade & arts >= 1.2.2
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/xmms-out-arts)
: unstable
: all Linux
: P2 major
Assigned To:
:
: http://lrn.ru/~mike/hpim1540.mpg
:
:
: 3459
  Show dependency tree
 
Reported: 2004-06-10 18:11 by
Modified: 2006-12-17 16:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-06-10 18:11:44
xmms-1.2.10-alt2
xmms-out-crossfade-0.3.4-alt2
xmms-out-arts-0.7.1-alt2
arts-1.2.2-alt3 or 1.2.3-alt1

  When I use xmms with out-crossfade and out-arts-0.7.1, sound playing is very 
strange. File "plays" some seconds and then skips some seconds (amounts of 
seconds depends on buffer sizes of arts and crossfade plugins). 


aRts plugin buffer: 1000 ms

mixing buffer: 1000 ms
plays ~1 sec., skips ~7 secs
mixing buffer: auto (7000 ms)
plays ~1 sec., skips ~15 secs
mixing buffer: 30000 ms
plays ~1 sec., skips ~29 secs
mixing buffer: 60000 ms
plays ~1 sec., skips ~46 secs


aRts plugin buffer: 200 ms

plays <1 sec., then skips some length (almost impossible to measure because of 
very short playing length)


aRts plugin buffer: 5000 ms

mixing buffer: auto (7000 ms)
plays ~4 secs, skips ~10 secs, plays ~10 secs, skips 4*10 secs (4 sequential 
jumps w/o pause), then plays ~10 secs, skips (3 or 4)*10 secs...

aRts plugin buffer: 10000 ms

mixing buffer: auto (7000 ms)
plays ~8 secs, skips ~22 secs, plays ~18 secs, skips >100 secs (in 3-4 
sequential jumps)...


  These lengths are measured using xmms time counter. Real sound behaves ever 
worse because of some additional buffering (crossfading?).
  When I use out-arts-0.6.0 (not 0.7.2) or arts-1.1.4 (not 1.2.x) all is OK.
------- Comment #1 From 2004-07-13 16:16:09 -------
Предлагаю собрать xmms без поддержки artsd
------- Comment #2 From 2004-07-13 17:46:52 -------
А сам xmms ни при чем. Поддержка-то в плагине.
------- Comment #3 From 2004-07-13 18:00:15 -------
wrar: 0.6.x работало нормально?  могу откатить на него -- виноват, не добрался
до xmms
------- Comment #4 From 2004-07-14 09:06:07 -------
mike: Работает прекрасно.
------- Comment #5 From 2004-07-14 09:23:29 -------
0.6?
------- Comment #6 From 2004-07-14 15:47:07 -------
Угу.
------- Comment #7 From 2004-08-04 17:13:05 -------
(In reply to comment #4)
> mike: Работает прекрасно.

А у меня хреново :(

/usr/share/xmms/xmms-wrapper.sh: init /home/mike/.xmms/config for uk_UA.KOI8-U
** artsd running, auto-enabling arts output plugin (found)

Segmentation fault

You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report.

Xlib: unexpected async reply (sequence 0x71c)!
------- Comment #8 From 2004-08-04 17:23:56 -------
$ rpmquery xmms-out-arts
xmms-out-arts-0.6.0-alt3

Тест проводился при включенном arts и при снесённом ~/.xmms

$ /usr/share/xmms/xmms-wrapper.sh
/usr/share/xmms/xmms-wrapper.sh: init /home/abr/.xmms/config for ru_RU.KOI8-R
** artsd running, auto-enabling arts output plugin (found)

Нарушение сегментации!

Скорее всего вы наткнулись на ошибку в XMMS. Пожалуйста, посетите
http://bugs.xmms.org и отправьте сообщение об ошибке.

Xlib: unexpected async reply (sequence 0x195d)!
------- Comment #9 From 2004-08-04 17:38:15 -------
Боюсь, это бага artsd (как и говорили zerg@ с google).

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=117056

2 zerg: имеется arts-1.2.3-alt2, kdemultimedia-arts-3.2.3-alt1 -- проблема есть.
Что посоветуешь делать?

С 0.7.1 описанная в данном багрепорте проблема _не_ вылазит у меня (на via8233),
но вылазит у wrar@;

с 0.6.0 -- работает у него, но вообще сегфолтается у меня.

Как вариант -- пишу README.ALT или строчку в LATEST-NOTES насчет "не заработает
-- отключите нафиг"?
------- Comment #10 From 2004-08-04 17:52:23 -------
(In reply to comment #9) 
> Боюсь, это бага artsd (как и говорили zerg@ с google). 
Дык это может из-за xmms-out-arts через soundwrapper? 
 
> Как вариант -- пишу README.ALT или строчку в LATEST-NOTES насчет "не 
заработает 
> -- отключите нафиг"? 
Можно. По-умолчанию ведь crossfade не включен. 
 
 
------- Comment #11 From 2004-08-04 17:58:46 -------
Угу.  И artsd по умолчанию не запущен.  Так что надо будет честно постараться
наступить на эти грабли :]
------- Comment #12 From 2004-08-04 18:22:20 -------
придется пока закрыть -- до выяснения судьбы arts (и механизма обработки --
плагином или через soundwrapper), т.е. явно после выпуска.

по крайней мере по умолчанию на эти грабли не наступить :]
------- Comment #13 From 2004-09-05 22:46:37 -------
Поменял мать, поэтому могу сказать, что от смены ALS4000 (snd-als4000) на VIA 
8237 (snd-via82xx) ничего не поменялось. Из меню работает, на 0.6.0 работает, а 
из консоли на 0.7.1 не работает.
------- Comment #14 From 2004-09-06 08:40:45 -------
Облин.  Я так и забыл откатить в сизифе на 0.6.0 :-[

Залито в incoming, выложено здесь:
http://linux.kiev.ua/~mike/RPM/SRPMS/xmms-out-arts-0.6.0-alt3.src.rpm
http://linux.kiev.ua/~mike/RPM/RPMS/i586/xmms-out-arts-0.6.0-alt3.i586.rpm

2 sbolskakov: уже/еще?  это некритично, поскольку конфигурация требует
установки
двух плагинов и настройки их именно в эту конфигурацию пользователем, но все
же.

(xmms-out-arts, надеюсь, по умолчанию не устанавливается? :))
------- Comment #15 From 2004-10-14 14:16:58 -------
*** Bug 5331 has been marked as a duplicate of this bug. ***
------- Comment #16 From 2004-12-01 15:04:52 -------
2 wrar, ns: а давайте вы как лица заинтересованные заберёте этот пакет? :)
------- Comment #17 From 2004-12-01 15:25:42 -------
(In reply to comment #16)
> 2 wrar, ns: а давайте вы как лица заинтересованные заберёте этот пакет? :)

wrar сказал, что уже не заинтересован... ;(

Похоже я остался один... совсем один...
------- Comment #18 From 2004-12-01 15:36:30 -------
NAS с тобой, какой один? :)

Забираешь?
------- Comment #19 From 2004-12-01 15:42:11 -------
У нас еще mas бесхозный есть. 
Spider отошел на неопределенное время. 
------- Comment #20 From 2004-12-01 15:54:56 -------
(In reply to comment #18)
> NAS с тобой, какой один? :)
Ааа.... 
> Забираешь?
А у меня есть выбор?..
------- Comment #21 From 2004-12-01 15:56:53 -------
(In reply to comment #19)
> У нас еще mas бесхозный есть. 
> Spider отошел на неопределенное время. 

Нее... я всего один!..

Так можно весь orphaned вытянуть на себя...
------- Comment #22 From 2004-12-01 15:59:01 -------
(In reply to comment #21) 
> Нее... я всего один!.. 
Я просто предложил, вдруг надо кому. 
> Так можно весь orphaned вытянуть на себя... 
Он пока не там 
 
------- Comment #23 From 2004-12-01 16:19:37 -------
Усё, финиш, занавес.
0.6.0 падает, 0.7.1 глючит. При том падает и без всякого crossfade. Симптомы 
аналогичны указанным выше.
arts-1.3.1-alt1
------- Comment #24 From 2004-12-01 16:24:39 -------
Кстати.

beep-0.9.7-alt0.7rc2
beep-output-arts-0.2.2-alt0.4
beep-output-crossfade-0.2.2-alt0.4

Ситуация та же, что с 0.7.1. С кроссфейдом глючит, без него работает.
------- Comment #25 From 2004-12-01 16:32:10 -------
А мож в obsolete? (умоляюще)
------- Comment #26 From 2004-12-01 16:37:01 -------
(In reply to comment #25)
> А мож в obsolete? (умоляюще)

С удовольствием бы... но MuNAS я еще не продизассемблил!.. ;)

Так что приходится юзать для передачи по сети эту каку!.. ;(((
------- Comment #27 From 2005-06-14 12:33:08 -------
Если ошибка актуальна для 3.0 - просьба сделать block на 7079
------- Comment #28 From 2005-06-14 14:30:43 -------
Если будет актуальна, out-arts просто похороним, ибо soundwrapper.

2 ns: ы?
------- Comment #29 From 2005-06-14 16:20:40 -------
Я не могу его похоронить... у меня выбор:
aRTSd или EsounD... Мне надо звук через сеть гонять... :(

И вообще мне например crossfade не нужен...
------- Comment #30 From 2005-06-14 16:30:47 -------
ну повесь conflicts:, если актуально :)
------- Comment #31 From 2005-06-14 17:52:09 -------
не смешно... оно не конфликтует реально... да и заниматься этим пакетом я буду
только если он у меня отвалится... как ты наверное помнишь, я его у тебя забрал
только чтобы обновить до 0.7.1...
------- Comment #32 From 2005-06-14 18:36:53 -------
сейчас оно работает? (да/нет)
------- Comment #33 From 2005-06-16 09:30:19 -------
xmms-1.2.10-alt4
arts-1.4.0-alt1
xmms-out-crossfade-0.3.4-alt2

xmms-out-arts-0.6.0-alt2 упал,
xmms-out-arts-0.7.1-alt2 "дергается".
------- Comment #34 From 2006-02-17 16:47:31 -------
актуально?
------- Comment #35 From 2006-02-17 17:45:08 -------
сие науке неизвестно...
------- Comment #36 From 2006-02-17 21:10:21 -------
(In reply to comment #34)
> актуально?
Меня давно не интересует данный баг. Что, впрочем, не означает его отсутствия.
------- Comment #37 From 2006-04-27 15:00:58 -------
У кого arts ышшо водится?
------- Comment #38 From 2006-04-29 21:58:26 -------
У меня... доживает последние дни... к лету выкину полностью наверное!..
------- Comment #39 From 2006-04-30 17:52:33 -------
Ну и ну его.