Bug 43773 - poetry-core: new version
Summary: poetry-core: new version
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: python3-module-poetry-core (show other bugs)
Version: unstable
Hardware: x86_64 Linux
: P5 normal
Assignee: Stanislav Levin
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-12 21:36 MSK by Yuri N. Sedunov
Modified: 2023-03-29 13:20 MSK (History)
19 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri N. Sedunov 2022-09-12 21:36:47 MSK
Похоже, нужна новая версия (1.1.0) с поддержкой групп зависимостей. Прошу обновить.

File "/usr/lib/python3/site-packages/poetry/core/factory.py", line 43, in create_poetry
    raise RuntimeError("The Poetry configuration is invalid:\n" + message)
RuntimeError: The Poetry configuration is invalid:
  - Additional properties are not allowed ('group' was unexpected)
Comment 1 Stanislav Levin 2022-09-13 11:04:56 MSK
Попробую собрать и проверить на регрессы.
Comment 2 Yuri N. Sedunov 2022-09-13 19:26:39 MSK
Спасибо. python3-module-pytest-httpserver-1.0.6, которoму нужен poetry-core-1.1 ждет в задании №306607.
Comment 3 Stanislav Levin 2022-09-14 15:33:09 MSK
В сизиф отправлен poetry-core 1.1.0:
https://lists.altlinux.org/pipermail/sisyphus-incominger/2022-September/670890.html
Comment 4 Stanislav Levin 2022-09-14 16:48:26 MSK
Спасибо, что собрали poetry ;)

Маленький нюанс.
Poetry перешел на implicit namespace, поэтому и появился дополнительный RPM пакет, который владеет рутами namespace'ов. Поэтому владеть %python3_sitelibdir/%pypi_name/ не корректно для poetry.
Comment 5 Yuri N. Sedunov 2023-03-28 20:58:14 MSK
Теперь poetry-1.4.1 хочет poetry-core-1.5.2. Ждём-с.
Comment 6 Repository Robot 2023-03-29 13:20:04 MSK
python3-module-poetry-core-1.5.2-alt1 -> sisyphus:

 Wed Mar 29 2023 Stanislav Levin <slev@altlinux> 1.5.2-alt1
 - 1.5.1 -> 1.5.2 (closes: #43773).