Bug 43883 - Не устанавливается Net Framework 3.5 SP1
Summary: Не устанавливается Net Framework 3.5 SP1
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: wine (show other bugs)
Version: unstable
Hardware: x86_64 Linux
: P5 normal
Assignee: Vitaly Lipatov
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-28 12:27 MSK by globonet
Modified: 2023-01-22 22:10 MSK (History)
5 users (show)

See Also:


Attachments
лог установки (11.64 KB, text/x-log)
2022-11-15 14:15 MSK, Pavel Shilov
no flags Details
проявление ошибки на 7.22 (379.35 KB, image/png)
2023-01-12 10:39 MSK, globonet
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description globonet 2022-09-28 12:27:39 MSK
На голом i586-wine

$ WINEARCH=win32 winecfg
$ winetricks dotnet35sp1

Устновка завершается ошибкой, ссылающийся на dotnet20
Установка dotnet20 эффекта не дает
Comment 1 Alexander Makeenkov 2022-09-28 12:34:08 MSK
Добрый день! 

Пожалуйста, предоставьте дополнительную информация для воспроизведения ошибки:
1) образ, на котором воспроизвелась ошибка
2) выводы команд
$ uname -a
$ cat /etc/os-release
$ apt-repo
3) версию пакета, на которой у Вас воспроизводится описанное поведение

Спасибо!
Comment 2 globonet 2022-09-28 12:42:45 MSK
Работа проводилась на Альт Рабочая станция 10 c версией пакета 7.17.1-alt1 (i586-wine)

$ uname -a
Linux kumi10-1.stavadm.ru 5.10.144-std-def-alt1 #1 SMP Tue Sep 20 21:17:09 UTC 2022 x86_64 GNU/Linux

$ cat /etc/os-release
NAME="ALT Workstation"
VERSION="10.0.910"
ID=altlinux
VERSION_ID=10.0.910
PRETTY_NAME="ALT Workstation 10.0.910 (Autolycus)"
ANSI_COLOR="1;33"
CPE_NAME="cpe:/o:alt:workstation:10.0.910"
BUILD_ID="ALT Workstation 10.0"
HOME_URL="https://basealt.ru/"
BUG_REPORT_URL="https://bugs.altlinux.org/"

$ apt-repo
rpm [p10] http://ftp.altlinux.org/pub/distributions/ALTLinux p10/branch/x86_64 classic
rpm [p10] http://ftp.altlinux.org/pub/distributions/ALTLinux p10/branch/noarch classic
rpm [p10] http://ftp.altlinux.org/pub/distributions/ALTLinux p10/branch/x86_64-i586 classic

Проблему установки получилось решить только откатившись до версии 7.16.1-alt2
Comment 3 Alexander Makeenkov 2022-09-28 13:10:25 MSK
Воспроизводится в сизифе.
Comment 4 globonet 2022-10-25 12:23:11 MSK
Просьба актуализировать информацию по багу в связи с выходом в сизифе новой версии
Comment 5 Pavel Shilov 2022-11-15 14:15:25 MSK
Created attachment 11857 [details]
лог установки
Comment 6 Pavel Shilov 2022-11-15 14:20:45 MSK
Версии пакетов 
wine-7.19.1-alt1.x86_64
wine-vanilla-7.19-alt1.x86_64

Ошибка выводится в ходе загрузки пакета с сервера, после 5-й попытки выводится сообщение о отправке отчета ошибки: "Не удается загрузить все необходимые файлы."
Лог установки приложен.
Comment 7 globonet 2023-01-12 10:39:25 MSK
Created attachment 12271 [details]
проявление ошибки на 7.22

При утановке на голой ОС Альт рабочая станция 10
С установленным пакетом i586-wine (версия 7.22)
Ошибка остается
Comment 8 Osmolovskaya Anastasia 2023-01-18 17:08:29 MSK
Похожее поведение наблюдается при установке .NET 2.0 SP2: 
$ WINEARCH=win32 WINEPREFIX=~/.dotnet20sp2_32 winetricks dotnet20sp2

Версия пакета: 
wine-7.22.1-alt1.x86_64
wine-mono-7.4.0-alt1.noarch
winetricks-20220617-alt1.noarch
Comment 9 Vitaly Lipatov 2023-01-22 22:10:27 MSK
Исправлено в winetricks-20230120-alt1.