Bug 44251 - epm play meridius: битые пакеты
Summary: epm play meridius: битые пакеты
Status: ASSIGNED
Alias: None
Product: Branch p10
Classification: Unclassified
Component: eepm (show other bugs)
Version: не указана
Hardware: x86_64 Linux
: P5 normal
Assignee: Vitaly Lipatov
QA Contact: qa-p10@altlinux.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-11-08 20:50 MSK by Vladislav Glinkin
Modified: 2023-01-25 18:06 MSK (History)
3 users (show)

See Also:


Attachments
Логи (7.95 KB, text/x-log)
2022-11-08 20:50 MSK, Vladislav Glinkin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav Glinkin 2022-11-08 20:50:39 MSK
Created attachment 11826 [details]
Логи

Стенды:
education-10-x86-64
education-10-x86-64-kde
kworkstation-10-x86-64
server-10-x86-64
workstation-10-x86-64

Версия пакета:
eepm-3.27.3-alt1

Шаги воспроизведения:
1) # epm play meridius

Фактический результат: Установка невозможна из-за битых пакетов.

Ожидаемый результат: Успешная установка.

В бранче p10 возможности установить meridius нету (из-за старой версии)

Логи прикрепляю
Comment 1 Vitaly Lipatov 2022-12-11 23:37:09 MSK
В p10 ставиться не будет. В Сизифе ставится.

Нужно пожаловаться разработчикам meridius, чтобы они собирали с более старой версией glibc (2.32 и ниже). Или можно ставить более старую версию. Интересует?
Comment 2 Anton Farygin 2022-12-17 16:18:14 MSK
Каким образом qa-team может помочь в этом вопросе ?

Проблему должен решать ментейнер. Возможно, надо просто убрать из eepm для p10 поддержку этого приложения.
Comment 3 Vitaly Lipatov 2022-12-17 19:46:47 MSK
(Ответ для Anton Farygin на комментарий #2)
> Каким образом qa-team может помочь в этом вопросе ?
Галочка ставится по умолчанию поменять ответственного. А у нас нечёткая история о том, кто поддерживает пакеты в бранчах.

> Проблему должен решать ментейнер.
Это какой-то новый подход. Надеюсь, что в данном случае мантейнер glibc? Ведь проблема в том, что нет GLIBC_2.35

> Возможно, надо просто убрать из eepm для
> p10 поддержку этого приложения.
Смотря какая цель.
Comment 4 AEN 2022-12-17 19:55:20 MSK
(In reply to Vitaly Lipatov from comment #3)
> (Ответ для Anton Farygin на комментарий #2)
> > Каким образом qa-team может помочь в этом вопросе ?
> Галочка ставится по умолчанию поменять ответственного. А у нас нечёткая
> история о том, кто поддерживает пакеты в бранчах.
> 
> > Проблему должен решать ментейнер.
> Это какой-то новый подход. Надеюсь, что в данном случае мантейнер glibc?
> Ведь проблема в том, что нет GLIBC_2.35
> 

Вряд ли будет. Через год p11. 

> > Возможно, надо просто убрать из eepm для
> > p10 поддержку этого приложения.
> Смотря какая цель.

Чтобы работало
Comment 5 Anton Farygin 2022-12-18 16:50:23 MSK
(Ответ для Vitaly Lipatov на комментарий #3)

> > Возможно, надо просто убрать из eepm для
> > p10 поддержку этого приложения.
> Смотря какая цель.

Цель - что бы в p10 работало без ошибок.

Если приложение не поддерживает p10, то и ставить его туда бесмысленно.
Comment 6 Vitaly Lipatov 2023-01-25 18:06:58 MSK
Исправлено в eepm-3.29.0, ждём в p10.