Bug 4487 - Wrong BuildRequires
: Wrong BuildRequires
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/ladccad)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-06-24 16:26 by
Modified: 2009-05-10 09:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-06-24 16:26:21
ladcca-0.4.0-alt0.6

В BuildRequires заменить freetype2 на freetype2-devel.
------- Comment #1 From 2004-06-24 16:27:44 -------
Имелось в виду ladcca-0.4.0-alt0.6.src.rpm.:)
------- Comment #2 From 2004-06-24 16:51:16 -------
(In reply to comment #0)
> ladcca-0.4.0-alt0.6
> 
> В BuildRequires заменить freetype2 на freetype2-devel.

Объясните, пожалуйста, зачем.
------- Comment #3 From 2004-06-25 08:27:01 -------
А зачем ему в BuildRequires freetype2?
У меня он захотел с ним слинковаться и естественно
обломался. Собирался в hasher'е на полугодовалой
давности сизифе. Если в новом freetype2 есть
соответствующие ссылки, характерные для *-devel
пакета, то тогда извиняюсь.:)
------- Comment #4 From 2004-06-25 13:44:09 -------
(In reply to comment #3)
> А зачем ему в BuildRequires freetype2?
> У меня он захотел с ним слинковаться и естественно
> обломался. Собирался в hasher'е на полугодовалой
> давности сизифе. Если в новом freetype2 есть
> соответствующие ссылки, характерные для *-devel
> пакета, то тогда извиняюсь.:)
> 

И не должен линковаться с freetype2.

$ rpm -q pkgconfig libtool_1.5
?
------- Comment #5 From 2004-06-28 08:27:07 -------
(In reply to comment #4)
> И не должен линковаться с freetype2.
> 
> $ rpm -q pkgconfig libtool_1.5
> ?

pkgconfig-0.15.0-alt1
libtool_1.5-1.5-alt7

По всей видимости его хочет libgtk+2-devel.:(
------- Comment #6 From 2004-06-28 14:31:39 -------
> pkgconfig-0.15.0-alt1
> libtool_1.5-1.5-alt7
 
Обновите pkgconfig до >= 0.15.0-alt3. 
------- Comment #7 From 2004-06-29 13:11:14 -------
(In reply to comment #6)
> Обновите pkgconfig до >= 0.15.0-alt3. 
Обновил до pkgconfig-0.15.0-alt3.2
все действительно собралось.:)
Вот что значит отрубить у него
рекурсию.:) Тем не менее я так и 
не понял зачем ему для сборки нужны
fontconfig и freetype2, но по всей
видимости это бага(возможно уже 
исправленная) buildreq.

Думаю баг можно закрывать.
------- Comment #8 From 2004-06-29 13:22:33 -------
(In reply to comment #7)
> (In reply to comment #6)
> > Обновите pkgconfig до >= 0.15.0-alt3. 
> Обновил до pkgconfig-0.15.0-alt3.2
> все действительно собралось.:)
> Вот что значит отрубить у него
> рекурсию.:) Тем не менее я так и 
> не понял зачем ему для сборки нужны
> fontconfig и freetype2, но по всей
> видимости это бага(возможно уже 
> исправленная) buildreq.

Нет. Эти зависимости появляются, потому-что:

$ pkg-config --cflags gtk+-x11-2.0
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include
-I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include

> Думаю баг можно закрывать.
Но закрывать все равно можно :) Вам это под силу. 

------- Comment #9 From 2004-06-29 14:11:12 -------
(In reply to comment #8)
> > Думаю баг можно закрывать.
> Но закрывать все равно можно :) Вам это под силу. 

ОК. Так как ladccad оказался здесь ни при чем
ставим INVALID. Спасибо за разъяснения. Удачи.