Bug 45002 - local-policy requires xmlbeans-scripts
Summary: local-policy requires xmlbeans-scripts
Status: UNCONFIRMED
Alias: None
Product: Branch p10
Classification: Unclassified
Component: local-policy (show other bugs)
Version: не указана
Hardware: x86_64 Linux
: P5 normal
Assignee: qa-team@altlinux.org
QA Contact: qa-p10@altlinux.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-01-23 14:55 MSK by Ivan A. Melnikov
Modified: 2023-01-25 11:09 MSK (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan A. Melnikov 2023-01-23 14:55:31 MSK
По всей видимости findreq путает функцию validate из /etc/control.d/functions и /usr/bin/validate из xmlbeans, в результате local-policy начинает тянуть за собой java.

Воспроизводится на p10 и догоняющих Сизифах, в которых xmlbeans-scripts ещё не удалены.
Comment 1 Ivan A. Melnikov 2023-01-23 15:26:31 MSK
В Сизиф предлагаю так:

https://git.altlinux.org/people/iv/packages/?p=local-policy.git;a=commitdiff;h=dc2e50f73205402378e8b928d78500978d6de725

[#313969] EPERM local-policy.git=0.6.0-alt1.1
Comment 2 Ivan Alekseev 2023-01-25 11:09:58 MSK
Ivan A. Melnikov, здравствуйте.
Просьба дополнить баг следующей информацией:
1) Образ на котором воспроизводится ошибка
2) Версия программы на которой воспроизводится ошибка
3) Шаги воспроизведения
4) Реальный результат
5) Ожидаемый результат