Bug 46197 - Liblua5.1 должен предоставлять зависимость на lua5.1(coroutine)
Summary: Liblua5.1 должен предоставлять зависимость на lua5.1(coroutine)
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: liblua5.1 (show other bugs)
Version: unstable
Hardware: all Linux
: P5 normal
Assignee: Vladimir D. Seleznev
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-05-19 21:05 MSK by Alexandr Shashkin
Modified: 2023-05-24 04:45 MSK (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Shashkin 2023-05-19 21:05:50 MSK
Liblua5.1 должен предоставлять зависимость на lua5.1(coroutine), как это происходит в liblua5.3.
Иначе приходится вручную убирать ее из зависимостей и прописывать на liblua5.1 к примеру здесь:
https://git.altlinux.org/tasks/320452/gears/570/git?p=git;a=commit;h=2430121d130092587a1d8f98a058130a6afac462
https://git.altlinux.org/tasks/320452/gears/1460/git?p=git;a=commit;h=4d517fca9f4984a998ca27336a54c11e32f57b0f
Также стоит учитывать что сама функциональность присутствует в lua5.1:
https://www.lua.org/manual/5.1/manual.html#2.11
Comment 1 Repository Robot 2023-05-24 04:45:58 MSK
lua5.1-5.1.5-alt21 -> sisyphus:

 Tue May 23 2023 Vladimir D. Seleznev <vseleznv@altlinux> 5.1.5-alt21
 - liblua5.1: provides lua5.1(coroutine) (closes: #46197).