Bug 4666 - Requires libdb.so.2
: Requires libdb.so.2
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/db4.3-utils)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-07-03 12:29 by
Modified: 2006-03-12 21:10 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-07-03 12:29:38
db4 utilities aren't supposed to link to db1, are they?
------- Comment #1 From 2004-07-10 20:17:37 -------
Do you suggest to remove /usr/bin/db_dump185?
------- Comment #2 From 2004-07-10 21:54:42 -------
(In reply to comment #1)
> Do you suggest to remove /usr/bin/db_dump185?

No, but... Can't it be linked statically to db1?
------- Comment #3 From 2004-07-10 21:56:20 -------
Reason?
------- Comment #4 From 2004-07-10 23:16:39 -------
Agreed. :)
------- Comment #5 From 2006-03-12 18:51:27 -------
Что-то не понял почему INVALID-то?

Проблема осталась:

[c0der@rock ~]$ rpm -qR db4.3-utils
...
libdb.so.2  
libdb.so.2(GLIBC_2.0)  
------- Comment #6 From 2006-03-12 19:30:39 -------
(In reply to comment #5)
> Что-то не понял почему INVALID-то?

Потому, что одной из утилит, db_dump185, для доступа к старому формату базы
нужна libdb1.

Думаю, нужно закрыть с тем же вердиктом.
------- Comment #7 From 2006-03-12 19:48:38 -------
(In reply to comment #6)
> Потому, что одной из утилит, db_dump185, для доступа к старому формату базы
> нужна libdb1.

А зачем эта программа вообще? Я вижу в пакете db_dump и db_dump185. В чем
разница и зачем их две версии?

Меня бы вообще не волновала судьба этого пакета, если бы он не вытянулся вслед
за libdb4.3-devel...

------- Comment #8 From 2006-03-12 20:13:51 -------
(In reply to comment #7)
> (In reply to comment #6)
> > Потому, что одной из утилит, db_dump185, для доступа к старому формату базы
> > нужна libdb1.
> 
> А зачем эта программа вообще?

Чтобы мигрировать с существующих баз формата 1.85.

> Меня бы вообще не волновала судьба этого пакета, если бы он не вытянулся вслед
> за libdb4.3-devel...

Вот с этого надо было начинать, и наверное, открыть новый баг.
Действительно, непонятно, зачем для разработки нужны утилиты.
------- Comment #9 From 2006-03-12 20:42:45 -------
(In reply to comment #8)
> Вот с этого надо было начинать, и наверное, открыть новый баг.
> Действительно, непонятно, зачем для разработки нужны утилиты.

Окей: https://bugzilla.altlinux.org/show_bug.cgi?id=9235
------- Comment #10 From 2006-03-12 21:10:20 -------
Может имеет смысл вынести её в подпакет, чтобы она не создавала лишних
зависимостей?