Bug 4817 - Хелперы аутентификации/авторизации wb_* не работают с текущим samba winbind API
: Хелперы аутентификации/авторизации wb_* не работают с текущим samba winbind API
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/squid)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-07-16 21:56 by
Modified: 2009-05-10 09:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-07-16 21:56:41
samba-3.0.3-alt1.1
squid-2.5.STABLE5-alt4

--- /var/log/messages ---
Jul 16 21:52:10 amarie winbindd[14589]: [2004/07/16 21:52:10, 0] nsswitch/winbin
dd.c:process_loop(726) 
Jul 16 21:52:10 amarie winbindd[14589]:   process_loop: Invalid request size fro
m pid 19895: 1304 bytes sent, should be 1824 
Jul 16 21:52:10 amarie winbindd[14589]:   This usually means that you are runnin
g old wbinfo, pam_winbind or libnss_winbind clients 
------------------------

Steps to Reproduce:
# service winbind status
winbindd is running
# wbinfo -p
Ping to winbindd succeeded on fd 4
# /usr/lib/squid/wb_ntlmauth
/wb_auth[19708](wb_basic_auth.c:160): Can't contact winbindd. Dying
# /usr/lib/squid/wb_ntlmauth
/wb_group[19719](wb_check_group.c:308): Can't contact winbindd. Dying
# /usr/lib/squid/wb_ntlmauth
wb_ntlmauth[19733](wb_ntlm_auth.c:416): Can't contact winbindd. Dying
------- Comment #1 From 2004-07-26 13:55:41 -------
Нсколько я знаю, чинить их никто и не собирается (в upstream squid team). Тема
эта  тянется еще с прошлого года, с момента выпуска samba3.
пользоваться надо самбовым ntlm-auth, работает. Другое дело, что из пакета
squid
надо нынешние выкинуть и указать как-то на самбовый ntlm-auth вместо них...
------- Comment #2 From 2005-05-18 14:19:07 -------
посмотрим
------- Comment #3 From 2005-05-18 14:28:09 -------
Сообщите пожалуйста текущее состояние.
------- Comment #4 From 2005-06-28 12:39:06 -------
?
------- Comment #5 From 2005-08-15 11:29:13 -------
Подтверждаю..не работает. ALM2.4
samba-3.0.14a-alt1.M24.1
squid-2.5.STABLE9-alt0.M24.1
------- Comment #6 From 2005-08-15 11:30:55 -------
Баг подтверждаю, но починить не обещаю.
------- Comment #7 From 2005-09-28 11:45:17 -------
Ремонту не подлежит.