Bug 4967 - Не работает обновление с 1.1.1 на 1.1.2 под пользователем
: Не работает обновление с 1.1.1 на 1.1.2 под пользователем
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/openoffice.org)
: unstable
: all Linux
: P5 blocker
Assigned To:
:
:
:
:
: 3459
  Show dependency tree
 
Reported: 2004-08-10 14:05 by
Modified: 2006-12-17 16:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-08-10 14:05:25
1)rpm -e openoffice.org openoffice.org-ru

2)apt-get install openoffice.org
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  openoffice.org-ru
The following NEW packages will be installed:
  openoffice.org openoffice.org-ru

3)rpm -qa|grep openoffice
openoffice.org-1.1.2-alt1
openoffice.org-ru-1.1.2-alt1

4) запускаем под пользователем

5) "чтение файла сценария..."; "Невозможно обновить версию: язык ОО 111
найденный в каталоге ~/OO111 отличается от языка устанавливаемой версии..."

6) жмем продолжить, возможность обновления отсутствует, жмем отмена, так-как
остается только вариант новой установки в ~/OO112, который не устраивает.

7) /usr/lib/OpenOffice.org/program/setofficelang.bin ru

ERROR: - An exception occurred: 'Cannot open Configuration: MultiStratumBackend:
Could not create Backend Strata Service:  Not a Valid File URL:
"/user/uno_packages/cache/registry"'
Тоже и под рутом. Это и понятно.

8) rpm -e openoffice.org-ru && apt-get install openoffice.org-ru --reinstall не
помогает

9) cat .sversionrc
[Versions]
OpenOffice.org 1.1.1=file:///home/gorev/OpenOffice.org1.1.1

10) rpm -q altlinux-release-Sisyphus
altlinux-release-Sisyphus-alt20040809
------- Comment #1 From 2004-08-18 19:23:54 -------
Это действительно неприятность, но на blocker она, как мне кажется, не тянет. В
конце концов, проблема решается установкой в новый каталог и перекладыванием
туда пользовательских файлов из старого.
------- Comment #2 From 2004-08-18 20:13:11 -------
1. block повесил не я, а rider. И я с ним согласен!
2. сижу и вижу сколько десятков раз саппорту придется отвечать на один и тот-же
дурацкий вопрос и тратить свое драгоценное время.
3. легко представить, какой флэйм поднимется в рассылках (как минимум трех).
4. если решение есть - его надо внедрить, чтобы все происходило автоматически
без участия пользователя. Сам по себе процесс "инсталляции" под пользователем
для неподготовленных людей уже стресс. Что говорить о необходимости манипуляций
на уровне файловой системы? Многие консоли-то никогда не видели.
------- Comment #3 From 2004-08-20 12:58:16 -------
Это blocker, ибо openoffice получается что не поддерживает единообразного
обновления.
Это криво.

Надо срочно лечить (и раньше было все нормально, пользователи уже привыкли к
тому, что оно само обновляется).
------- Comment #4 From 2004-08-31 14:33:11 -------
Исправлено в 1.1.2-alt2