Bug 4995 - gnumeric-1.2.13-alt1 Ошибки при инициализации системы дополнений.
: gnumeric-1.2.13-alt1 Ошибки при инициализации системы дополнений.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gnumeric)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-08-13 23:37 by
Modified: 2005-08-29 02:12 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-08-13 23:37:19
При старте появляется окно с сообщением:

Ошибки при инициализации системы дополнений.
Ошибки при считывании информации о доступных дополнениях.
При чтении информации о дополнении из файла
"/usr/lib/gnumeric/1.2.13-bonobo/plugins/fn-info/plugin.xml" возникла ошибка.
Файл "/usr/lib/gnumeric/1.2.13-bonobo/plugins/fn-info/plugin.xml" не является
допустимым файлом информации о дополнении.

При этом дополнения инциализируются.
------- Comment #1 From 2004-08-23 11:59:11 -------
(In reply to comment #0)
> При старте появляется окно с сообщением:
> 
> Ошибки при инициализации системы дополнений.
> Ошибки при считывании информации о доступных дополнениях.
> При чтении информации о дополнении из файла
> "/usr/lib/gnumeric/1.2.13-bonobo/plugins/fn-info/plugin.xml" возникла ошибка.
> Файл "/usr/lib/gnumeric/1.2.13-bonobo/plugins/fn-info/plugin.xml" не является
> допустимым файлом информации о дополнении.
> 
> При этом дополнения инциализируются.

С gnumeric-1.2.13-alt1 на текущем Сизифе эта ошибка не воспроизводится.
------- Comment #2 From 2004-09-03 14:35:21 -------
Ошибка действительно есть. Исправлена в gnumeric-1.2.13-alt1.1
------- Comment #3 From 2004-12-15 17:12:48 -------
Проблема в том, что в Master 2.4 попала именно версия gnumeric-1.2.13-alt1
содержащая указаную ошибку.
В updates нового пакета gnumeric нет. В Сизифе уже gnumeric-1.4.0-alt1.i586.rpm

Как быть пользователям Мастера 2.4?
------- Comment #4 From 2004-12-15 18:00:51 -------
(In reply to comment #3)
> Проблема в том, что в Master 2.4 попала именно версия gnumeric-1.2.13-alt1
> содержащая указаную ошибку.

М-да, встретите sbolshakov@ в реале, как сможете поблагодарите его за отличную
работу.

> В updates нового пакета gnumeric нет. В Сизифе уже gnumeric-1.4.0-alt1.i586.rpm
> 
> Как быть пользователям Мастера 2.4?

Ждать появления какого-нибудь гнумерика в updates к Мастеру.
------- Comment #5 From 2004-12-15 18:34:32 -------
(In reply to comment #4)
> (In reply to comment #3)
> > Проблема в том, что в Master 2.4 попала именно версия gnumeric-1.2.13-alt1
> > содержащая указаную ошибку.
> 
> М-да, встретите sbolshakov@ в реале, как сможете поблагодарите его за отличную
> работу.

Ох доберусь я до него на ближайшем LinuxFest.... блин :-\ Много нареканий у меня
к Мастеру накопилось даже при первичном рассмотрении. 

> 
> > В updates нового пакета gnumeric нет. В Сизифе уже gnumeric-1.4.0-alt1.i586.rpm
> > 
> > Как быть пользователям Мастера 2.4?
> 
> Ждать появления какого-нибудь гнумерика в updates к Мастеру.

А ожидается в updates? А есть гарантии что в updates попадёт именно версия
исправленная из 1.2.13-alt1.1 а не 1.2.13-alt1 ??

Суть вот в чем. Мастер - продукт долгоиграющий, цикл его жизни год-полтора. Если
ещё сейчас (наверное) можно безболезненно поставить gnumeric из Сизифа в Мастер
2.4, то уже через полгода Сизиф так уйдёт вперед, что gnumeric вытянет за собой
пол системы и такое обновление многим будет просто не по зубам/кошелькам.
------- Comment #6 From 2004-12-15 18:58:04 -------
> А ожидается в updates? А есть гарантии что в updates попадёт именно версия
> исправленная из 1.2.13-alt1.1 а не 1.2.13-alt1 ??

Большаков тут не сможет помешать.

> Суть вот в чем. Мастер - продукт долгоиграющий, цикл его жизни год-полтора. Если
> ещё сейчас (наверное) можно безболезненно поставить gnumeric из Сизифа в Мастер
> 2.4, то уже через полгода Сизиф так уйдёт вперед, что gnumeric вытянет за собой
> пол системы и такое обновление многим будет просто не по зубам/кошелькам.
> 

Олег, возможно, по скудости ума я не понял, о чем ты беспокоишься :). Мы же
обсуждаем гнумерик, предназначенный в updates для М24, а не backports к М24 из
Сизифа.
------- Comment #7 From 2004-12-15 19:11:10 -------
(In reply to comment #6)
> > А ожидается в updates? А есть гарантии что в updates попадёт именно версия
> > исправленная из 1.2.13-alt1.1 а не 1.2.13-alt1 ??
> 
> Большаков тут не сможет помешать.

;-)
 
> Олег, возможно, по скудости ума я не понял, о чем ты беспокоишься :). Мы же
> обсуждаем гнумерик, предназначенный в updates для М24, а не backports к М24 из
> Сизифа.

Ну тогда ждем его в updates :-)

------- Comment #8 From 2004-12-16 00:35:43 -------
Мы же
> > обсуждаем гнумерик, предназначенный в updates для М24, а не backports к М24 из
> > Сизифа.
> 
> Ну тогда ждем его в updates :-)

Так, обойтись без дополнительных пакетов, можно сказать, не удалось :). Собран
все же gnumeric-1.4.1, ему совершенно необходима libgsf посвежее и новые
docbook-dtds. Также, пользуясь случаем я обновил и glib/gtk до последних из
ветки 2.4. Все это теоретически не должно ничего сломать. Все добро выложено в
виде отдельного репозитория в ftp://ftp.altlinux.ru/pub/people/aris/RPMS/m24/.

Прошу тестировать. Если все будет хорошо, уйдет в updates.


 

------- Comment #9 From 2004-12-16 19:46:43 -------
> Все это теоретически не должно ничего сломать. Все добро выложено в
> виде отдельного репозитория в ftp://ftp.altlinux.ru/pub/people/aris/RPMS/m24/.
> 
> Прошу тестировать. Если все будет хорошо, уйдет в updates.

Натравил туда apt-get, обновлялся через dist-upgrade. У меня обновления
потребовали пакеты:
docbook-dtds
glib2
libgsf
libgtk+2
libgsf-gnome
gnumeric
Всё установилось нормально.
Проверил функционирование gnumeric, gimp, mozilla, vmware под KDE и под Gnome.
Проблем не наблюдаю :-)
Спасибо!
------- Comment #10 From 2004-12-16 20:32:09 -------
> Проблем не наблюдаю :-)
> Спасибо!

Спасибо за тестирование :).