Bug 50122 - Конфликты при обновлении до filesystem 3.1
Summary: Конфликты при обновлении до filesystem 3.1
Status: CLOSED NOTABUG
Alias: None
Product: Sisyphus
Classification: Development
Component: filesystem (show other bugs)
Version: unstable
Hardware: x86_64 Linux
: P5 normal
Assignee: placeholder@altlinux.org
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-04-23 09:31 MSK by Sergei Naumov
Modified: 2024-07-06 19:16 MSK (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei Naumov 2024-04-23 09:31:02 MSK
Совершаем изменения...
filesystem-3.1-alt1: Migration is needed before the package can be installed.
ошибка: lua script failed: [string "%pretrans(filesystem-3.1-alt1.x86_64)"]:29: Looks like usrmerge-hier-convert is not installed. Aborting.
Подготовка...                                                               #################################################################################################### [100%]
        файл /bin из устанавливаемого пакета filesystem-3.1-alt1.x86_64 конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
        файл /lib из устанавливаемого пакета filesystem-3.1-alt1.x86_64 конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
        файл /lib64 из устанавливаемого пакета filesystem-3.1-alt1.x86_64 конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
        файл /libx32 из устанавливаемого пакета filesystem-3.1-alt1.x86_64 конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
        файл /sbin из устанавливаемого пакета filesystem-3.1-alt1.x86_64 конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
E: Ошибка во время исполнения транзакции
Comment 1 GordeevM 2024-04-23 15:14:14 MSK
точно не хватает вот этого пакета: usrmerge-hier-convert

Установил этот пакет, потом принудительно запустил установку.. вроде бы.. ничего не поломало 

rpm -U --force  /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.1@1713620017_x86%5f64.rpm
Comment 2 Arseny Maslennikov 2024-04-23 15:41:30 MSK
(In reply to Sergei Naumov from comment #0)
> Совершаем изменения...
> filesystem-3.1-alt1: Migration is needed before the package can be installed.
> ошибка: lua script failed: [string
> "%pretrans(filesystem-3.1-alt1.x86_64)"]:29: Looks like
> usrmerge-hier-convert is not installed. Aborting.
> Подготовка...                                                              
> #############################################################################
> ####################### [100%]
>         файл /bin из устанавливаемого пакета filesystem-3.1-alt1.x86_64
> конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
>         файл /lib из устанавливаемого пакета filesystem-3.1-alt1.x86_64
> конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
>         файл /lib64 из устанавливаемого пакета filesystem-3.1-alt1.x86_64
> конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
>         файл /libx32 из устанавливаемого пакета filesystem-3.1-alt1.x86_64
> конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
>         файл /sbin из устанавливаемого пакета filesystem-3.1-alt1.x86_64
> конфликтует с файлом из пакета filesystem-2.3.19-alt1.x86_64
> E: Ошибка во время исполнения транзакции

Ясно же пишут:
> Looks like usrmerge-hier-convert is not installed. Aborting.

Это обычный пакет в сизифе; его нужно установить.

https://altlinux.org/Usrmerge#FAQ

Способа сделать совсем "по красоте" имеющимися инструментами, наверное, не существует. Может быть, мы что-то придумаем для процедуры обновления с p10.
Comment 3 Arseny Maslennikov 2024-04-23 15:46:23 MSK
(In reply to GordeevM from comment #1)
> точно не хватает вот этого пакета: usrmerge-hier-convert
> 
> Установил этот пакет, потом принудительно запустил установку.. вроде бы..
> ничего не поломало 
> 
> rpm -U --force 
> /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.
> 1@1713620017_x86%5f64.rpm

Вроде того, да.

Кого пугает прямой вызов rpm, тем должно быть достаточно просто:
apt-get install usrmerge-hier-convert
apt-get dist-upgrade
Comment 4 Sergei Naumov 2024-04-23 23:05:56 MSK
(Ответ для Arseny Maslennikov на комментарий #3)
> (In reply to GordeevM from comment #1)
> > точно не хватает вот этого пакета: usrmerge-hier-convert
> > 
> > Установил этот пакет, потом принудительно запустил установку.. вроде бы..
> > ничего не поломало 
> > 
> > rpm -U --force 
> > /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.
> > 1@1713620017_x86%5f64.rpm
> 
> Вроде того, да.
> 
> Кого пугает прямой вызов rpm, тем должно быть достаточно просто:
> apt-get install usrmerge-hier-convert
> apt-get dist-upgrade

А чего зависимость не поставили в пакете?
Comment 5 Andrey 2024-05-03 11:58:33 MSK
(Ответ для GordeevM на комментарий #1)
> точно не хватает вот этого пакета: usrmerge-hier-convert
> 
> Установил этот пакет, потом принудительно запустил установку.. вроде бы..
> ничего не поломало 
> 
> rpm -U --force 
> /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.
> 1@1713620017_x86%5f64.rpm


Не устанавливается как раз этот пакет:

# rpm -U --force  /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.1@1713620017_x86%5f64.rpm
filesystem-3.1-alt1: Migration is needed before the package can be installed.
filesystem-3.1-alt1: Starting usrmerge-hier-convert...
usr-m: Making a copy of `/bin'.
usr-m: Detecting relative symlinks in `/bin' that would break.
'/usr/bin.usrmerge/rpm' -> '../../usr/bin/rpm'
usr-m: Resolving conflicts of `/bin' and `/usr/bin'.
usr-m: N: Will replace /bin/ping6 with /usr/bin/ping6
usr-m: N: Will replace /bin/bzcat with /usr/bin/bzcat
usr-m: N: Will replace /bin/zcat with /usr/bin/zcat
usr-m: N: Will replace /bin/rpm with /usr/bin/rpm
usr-m: N: Will replace /bin/tracepath6 with /usr/bin/tracepath6
usr-m: N: Will replace /bin/tracepath with /usr/bin/tracepath
usr-m: N: Will replace /bin/awk with /usr/bin/awk
usr-m: N: Will replace /bin/gunzip with /usr/bin/gunzip
usr-m: N: Will replace /bin/bunzip2 with /usr/bin/bunzip2
usr-m: N: Will replace /bin/ping with /usr/bin/ping
usr-m: N: Will replace /usr/bin/tput with /bin/tput
usr-m: N: Will replace /usr/bin/xargs with /bin/xargs
usr-m: N: Will replace /usr/bin/deallocvt with /bin/deallocvt
usr-m: N: Will replace /usr/bin/find with /bin/find
usr-m: N: Will replace /usr/bin/zsh with /bin/zsh
usr-m: N: Will replace /usr/bin/fgconsole with /bin/fgconsole
usr-m: N: Will replace /usr/bin/cut with /bin/cut
usr-m: N: Will replace /usr/bin/dbus-send with /bin/dbus-send
usr-m: N: Will replace /usr/bin/unicode_start with /bin/unicode_start
usr-m: N: Will replace /usr/bin/openvt with /bin/openvt
usr-m: N: Will replace /usr/bin/gawk with /bin/gawk
usr-m: N: Will replace /usr/bin/du with /bin/du
usr-m: N: Will replace /usr/bin/taskset with /bin/taskset
usr-m: N: Will replace /usr/bin/sort with /bin/sort
usr-m: N: Will replace /usr/bin/cat with /bin/cat
usr-m: N: Will replace /usr/bin/wc with /bin/wc
usr-m: N: Will replace /usr/bin/tail with /bin/tail
usr-m: N: Will replace /usr/bin/head with /bin/head
usr-m: N: Will replace /usr/bin/gzip with /bin/gzip
usr-m: N: Will replace /usr/bin/kbd_mode with /bin/kbd_mode
usr-m: N: Will replace /usr/bin/chvt with /bin/chvt
usr-m: N: Will replace /usr/bin/bzip2 with /bin/bzip2
usr-m: N: Will replace /usr/bin/dbus-launch with /bin/dbus-launch
usr-m: N: Will replace /usr/bin/systemctl with /bin/systemctl
usr-m: N: Will replace /usr/bin/dumpkeys with /bin/dumpkeys
usr-m: N: Will replace /usr/bin/mkfifo with /bin/mkfifo
usr-m: N: Will replace /usr/bin/getopt with /bin/getopt
usr-m: N: Will replace /usr/bin/kill with /bin/kill
usr-m: N: Will replace /usr/bin/bzip2recover with /bin/bzip2recover
usr-m: N: Will replace /usr/bin/install with /bin/install
usr-m: N: Will replace /usr/bin/unicode_stop with /bin/unicode_stop
usr-m: N: Will replace /usr/bin/setfont with /bin/setfont
usr-m: E: /bin/ex conflicts with /usr/bin/ex; not resolving.
: /bin/ex:     symbolic link to vi
: /usr/bin/ex: symbolic link to vim
: Exiting.
usr-m: No potentially destructive changes done, cleaning up.
ошибка: lua script failed: [string "%pretrans(filesystem-3.1-alt1.x86_64)"]:32: exit
ошибка: filesystem-3.1-alt1.x86_64: установить пропущено
ошибка: filesystem-2.3.18-alt1.x86_64: стереть пропущено

С таким кто-то сталкивался? В поиске не нашел похожей ошибки.
Comment 6 Arseny Maslennikov 2024-05-03 12:57:20 MSK
> Не устанавливается как раз этот пакет:
> 
> # rpm -U --force 
> /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.
> 1@1713620017_x86%5f64.rpm
> filesystem-3.1-alt1: Migration is needed before the package can be installed.
> filesystem-3.1-alt1: Starting usrmerge-hier-convert...
> <...>
> usr-m: E: /bin/ex conflicts with /usr/bin/ex; not resolving.
> : /bin/ex:     symbolic link to vi
> : /usr/bin/ex: symbolic link to vim
> : Exiting.
> usr-m: No potentially destructive changes done, cleaning up.
> 
> С таким кто-то сталкивался? В поиске не нашел похожей ошибки.

Надо обновить те пакеты, в которых соответственно упакованы /bin/ex и /usr/bin/ex.
  apt-get install vim-minimal vim-common
После этого попробовать dist-upgrade.
Comment 7 Tatyana Gagina 2024-07-06 19:16:35 MSK
(Ответ для Arseny Maslennikov на комментарий #6)
> > Не устанавливается как раз этот пакет:
> > 
> > # rpm -U --force 
> > /var/cache/apt/archives/filesystem_3.1-alt1%3asisyphus+345302.300.2.
> > 1@1713620017_x86%5f64.rpm
> > filesystem-3.1-alt1: Migration is needed before the package can be installed.
> > filesystem-3.1-alt1: Starting usrmerge-hier-convert...
> > <...>
> > usr-m: E: /bin/ex conflicts with /usr/bin/ex; not resolving.
> > : /bin/ex:     symbolic link to vi
> > : /usr/bin/ex: symbolic link to vim
> > : Exiting.
> > usr-m: No potentially destructive changes done, cleaning up.
> > 
> > С таким кто-то сталкивался? В поиске не нашел похожей ошибки.
> 
> Надо обновить те пакеты, в которых соответственно упакованы /bin/ex и
> /usr/bin/ex.
>   apt-get install vim-minimal vim-common
> После этого попробовать dist-upgrade.

Помогло это решение, спасибо! Предварительно выполнив:                                         # apt-get install usrmerge-hier-convert && apt-get dist-upgrade