Bug 5016 - upgrade ALC2.3+contrib to ALM2.4beta5 & kdelibs
: upgrade ALC2.3+contrib to ALM2.4beta5 & kdelibs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kdelibs)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-08-18 16:18 by
Modified: 2006-08-26 21:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-08-18 16:18:20
Тема: [Comm] ALM2.2 -> ALC2.3+Contrib -> ALM2.4beta5
Дата: Mon, 16 Aug 2004 04:07:35 -0500
От: Denis G. Samsonenko <earthsea@ngs.ru>
Отвечать: community@altlinux.ru
Кому: community@altlinux.ru, sisyphus <sisyphus@altlinux.ru>

<skiped>

Система у меня такая: Когда-то стоял АЛМ2.0, который в своё время бул 
успешно обновлён до АЛМ2.2. Потом я скачал Компакт 2.3 + контриб к нему 
и обновил уже этот самый АЛМ2.2. А вот теперь я обновился до беты АЛМ2.4 
(версия 20040728).

Далее dist-upgrade мне предложил снести kdebase со всем, что от него 
зависит. Ладно, я от этого отказался, решил пообновлять немного вручную. 
Выяснилось, что kdebase обновляться не хочит, так как какой-то из 
зависимых пакетов конфликтует со старым kde-i18-ru. Хорошо, apt-get 
remove его. После чего снова apt-get install kdebase, на что он мне 
сказал, что надо libcrypto.so.4 и libssl.so.4 и поставить он их не может.

В итоге я подобрал такую строку, при которой он почти ничего важного 
сносить не захотел:

apt-get install libssl kdelibs kdebase cups nmap

После чего уже доставил kde-i18-ru.

<skiped>
------- Comment #1 From 2005-08-10 17:44:12 -------
Я ослабил некоторые зависимости, не должно воспроизводиться  
------- Comment #2 From 2006-08-26 21:06:03 -------
за давностью лет