Bug 5135 - gdb not stop on breakpoints, placed in class constructors
: gdb not stop on breakpoints, placed in class constructors
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/gdb)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-09-01 08:13 by
Modified: 2005-07-13 15:46 (History)


Attachments
тестовый пример (111 bytes, text/plain)
2004-09-01 08:17, partizan
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-09-01 08:13:22
При попытке пошаговой отладки gdb входит в конструктор, но судя по адресу
функции, он входит в соседнюю функцию (смещение порядка +20h от точки
останова).
------- Comment #1 From 2004-09-01 08:17:16 -------
Created an attachment (id=587) [details]
тестовый пример
------- Comment #2 From 2004-09-01 19:43:07 -------
Unable to reproduce, tested with "g++ -g -O2".