Bug 5514 - postgresql crashed on plperlu function
: postgresql crashed on plperlu function
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/postgresql)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-11-16 15:39 by
Modified: 2008-08-02 03:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-16 15:39:07
Обнаружил при перезде базы с Мастера 2.0 на последний сизиф - функции plperlu
которые работали стали вызывать падение сервера...


Steps to Reproduce:
1.#psql some_database;

2.s_m=#CREATE FUNCTION plperl_call_handler () RETURNS language_handler
    AS '$libdir/plperl', 'plperl_call_handler'
    LANGUAGE c;


3.s_m=#CREATE PROCEDURAL LANGUAGE plperlu HANDLER plperl_call_handler;

4.s_m=#CREATE FUNCTION test() RETURNS integer AS '
    return 1;
' LANGUAGE plperlu;

5.s_m=# select test();
server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.
The connection to the server was lost. Attempting reset: Failed. !>  


Actual Results:  
server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.
The connection to the server was lost. Attempting reset: Failed. !>  



Expected Results:  
1
------- Comment #1 From 2005-02-12 14:10:30 -------
*** Bug 6100 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-06-20 02:38:41 -------
Буду смотреть.
Причины этого кто-нибудь уже исследовал?
------- Comment #3 From 2005-06-20 18:33:55 -------
я к примеру не знаю как - но с 8(а там фичи перловые новые) тоже не работает
(интересно как в мастере 24)..
мне так мнилось что надо перл и пост собирать вместе...но я не пробовал...
------- Comment #4 From 2006-09-28 22:54:32 -------
Случайно не из-за chroot?
------- Comment #5 From 2006-10-19 02:08:10 -------
perl с postgresql в chroot нормально работать не будет.
Либо вытаскивайте из chroot, либо не используйте plperl.

В любом случае пакет postgresql (то бишь версии < 8) более не поддерживаются