Bug 5643 - неправильные зависимости
: неправильные зависимости
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/openoffice.org)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-07 12:02 by
Modified: 2005-08-29 01:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-07 12:02:38
$ rpm -qa | grep openoffice
openoffice.org-ru-1.1.2-alt5
openoffice.org-1.1.3-alt1

$ oowriter 
/usr/bin/ooffice: line 1: /usr/lib/OpenOffice.org/program/instdb.ins: No such
file or directory

По-хорошему, пакет openoffice.org должен хотеть хотя бы один языковый пакет,
но можно пакету openoffice.org-(en|ru) поставить зависимость на openoffice.org.
------- Comment #1 From 2004-12-08 23:30:09 -------
Все эти зависимости есть. Какой-то у вас upgrade произошел неполноценный.
Воизбежании подобных инцидентов придется поставить depends на точную версию.

[sacha@salto RPMS.hasher]$ rpm -qRp openoffice.org-1.1.3-alt1.i586.rpm|grep
openoffice
openoffice.org-lang  
[sacha@salto RPMS.hasher]$ rpm -qRp openoffice.org-ru-1.1.3-alt1.i586.rpm|grep
openoffice
openoffice.org  
[sacha@salto RPMS.hasher]$ rpm -qRp openoffice.org-en-1.1.3-alt1.i586.rpm|grep
openoffice
openoffice.org  
[sacha@salto RPMS.hasher]$ rpm -qp openoffice.org-ru-1.1.3-alt1.i586.rpm
--provides|grep openoffice
openoffice.org-lang  
openoffice.org-ru = 1.1.3-alt1
[sacha@salto RPMS.hasher]$ rpm -qp openoffice.org-en-1.1.3-alt1.i586.rpm
--provides|grep openoffice
openoffice.org-lang  
openoffice.org-en = 1.1.3-alt1
------- Comment #2 From 2004-12-31 02:04:27 -------
Fixed in 1.1.4-alt1