Bug 5667 - missed requires
: missed requires
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/IceWMCP)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-10 12:32 by
Modified: 2005-09-04 22:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-10 12:32:54
# apt-get install IceWMCP-3.2-alt1.noarch.rpm 
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано IceWMCP для 'IceWMCP-3.2-alt1.noarch.rpm'
Следующие дополнительные пакеты будут установлены:
  IceWMCP python-strict

[skip]

# icepref
You do not have PyGtk-2 or one of its libraries properly installed.
This application requires PyGtk-2 1.99/2.00 or better.
------- Comment #1 From 2004-12-10 18:37:04 -------
(In reply to comment #0)
> 
> [skip]
А вот можно без [skip]? Я не пойму, откуда это сообщение вылезает, не могу щас
проверить. requires: pygtk2 в спеке есть
> 
> # icepref
> You do not have PyGtk-2 or one of its libraries properly installed.
> This application requires PyGtk-2 1.99/2.00 or better.
------- Comment #2 From 2004-12-10 22:08:09 -------
Я скипнул прогресс скачивания и установки IceWMCP и python-strict, а также
удаление python-relaxed, python22-devel и python22, так как в них не было
ничего
необычного и заслуживающего внимания. Вылезает оно при попытке запуска. Если Вы
говорите, что с зависимостями всё в порядке, значит что-то с самим icepref
неладно. Хотя и не исключено, что непорядок в PyGtk. Только-что я повторил
процедуру установки и запуска этого пакета на другой машине - теже яйца, вид
сбоку. На этот раз привожу полный вывод процесса установки.

$apt-get install IceWMCP
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  python-dev python-module-pygtk
Следующие НОВЫЕ пакеты будут установлены:
  IceWMCP python-dev python-module-pygtk
0 будет обновлено, 3 новых установлено, 0 пакетов будет удалено и 3 не будет
обновлено.
Необходимо получить 0B/1656kB архивов.
После распаковки потребуется дополнительно 5337kB дискового пространства.
Продолжить? [Y/n]
Совершаем изменения...
Preparing...                
########################################################################################
[100%]
1: python-dev               
########################################################################################
[ 33%]
2: python-module-pygtk      
########################################################################################
[ 66%]
3: IceWMCP                  
########################################################################################
[100%]
Завершено.
$ icepref
You do not have PyGtk-2 or one of its libraries properly installed.
This application requires PyGtk-2 1.99/2.00 or better.
------- Comment #3 From 2005-07-10 21:46:18 -------
Сегодня уйдет новая сборка, проверь, как там будет :)
------- Comment #4 From 2005-07-13 16:05:11 -------
Работает.