Bug 5703 - не находим модуль для usb-контролера (не правильно определяем!)
: не находим модуль для usb-контролера (не правильно определяем!)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libhw)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-15 02:11 by
Modified: 2008-09-16 15:24 (History)


Attachments
патч для базы. (537 bytes, patch)
2004-12-15 02:12, ReMaks
no flags Details | Diff
патч для автоопределялки. (569 bytes, patch)
2004-12-15 02:13, ReMaks
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-15 02:11:39
имеем
2.6.9-std26-up-alt11
libhw-tools-0.2.2-alt1
libhw-0.2.2-alt1
hwdatabase-0.1.8-alt1

хотим usb.
# pciscan -c 00c:03 
Recommended driver     Description
------------------     -----------
usb-uhci               Intel Corporation|82371AB PIIX4 USB[USB Controller]

а должно быть 
# pciscan -c 00c:03 -k 2.6
Recommended driver     Description
------------------     -----------
uhci-hcd               Intel Corporation|82371AB PIIX4 USB[USB Controller]

вроде как патчи даже получились...
------- Comment #1 From 2004-12-15 02:12:48 -------
Created an attachment (id=666) [details]
патч для базы.

патч для базы.
------- Comment #2 From 2004-12-15 02:13:46 -------
Created an attachment (id=667) [details]
патч для автоопределялки.

патч для автоопределялки.
------- Comment #3 From 2004-12-16 10:57:38 -------
Патч для определялки не нужен.
Она сама смотрит на версию ядра.

В hwdatabase принято. В следующей версии будет исправлено.
------- Comment #4 From 2004-12-16 11:53:36 -------
(In reply to comment #3)
> Патч для определялки не нужен.
> Она сама смотрит на версию ядра.
> В hwdatabase принято. В следующей версии будет исправлено.

в том то и прикол, что должна определять ядро, но не определяет. Если 
принудительно указать версию, как в патче, то все ок.
иначе несмотря на версию ядра берем первую строчку, в которой укзано что 
использоваь драйвер для 2.4 (usb-uhci), а не uhci-hcd. И из-за этого у меня не 
работал usb.

ЗЫ: мать 440LX, kernel 2.6.8 & 2.6.9
 
------- Comment #5 From 2004-12-16 12:53:58 -------
Так это проблема в другом месте зарыта. 

Исправлено в следующей версии libhw.
------- Comment #6 From 2004-12-16 13:38:17 -------
(In reply to comment #5)
> Так это проблема в другом месте зарыта. 
> Исправлено в следующей версии libhw.

"такую же, но только перламутровую" - "будем искать" (с)

верить на слово не буду - :)
проверю - доложу
------- Comment #7 From 2004-12-16 14:00:59 -------
Проверяйте:
ftp://ftp.altlinux.ru/pub/people/rider/libhw/
------- Comment #8 From 2004-12-16 14:02:50 -------
Да, при этом патч на hwdatabase не нужен.