Bug 5739 - SWIG Bindigs for perl and java are not packaged.
: SWIG Bindigs for perl and java are not packaged.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/subversion)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-19 04:06 by
Modified: 2005-06-09 11:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-19 04:06:48
SubVersion содержит SWIG-интерфейсы к Яве, Перлу и Питону, но в Альтовской 
сборке генерируется только питоновский интерфейс. А как же Перл? И у Сусе, и у 
Федоры сборка этого пакета производится. Без него не собрать ни perl-SVN-Push, 
ни perl-SVN-Mirror, а без этого IMHO шансы SubVersion стать единой альтовской 
системой хранения проектов минимальны.
Steps to Reproduce:
1. apt-get install subversion-perl
Actual Results:  
E: Couldn't find package subversion-perl


Expected Results:  
All ok, installed.
------- Comment #1 From 2004-12-20 01:16:23 -------
Заточка под это у меня уже есть некоторое время локально, перловый биндинги
даже
собирались нормально... вот только не хватает времени допилить это все,
разложить правильно...
Но раз уж надо - постараюсь в этом году закончить... :)
------- Comment #2 From 2004-12-27 20:06:00 -------
В 1.1.2-alt1 собираются перловые биндинги.
Явовские пока еще не готовы...
------- Comment #3 From 2005-06-09 11:49:56 -------
JavaHL биндинги также собираются, начиная с 1.1.3-alt1