Bug 5806 - Не запускается.
: Не запускается.
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/dia)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-01-01 16:34 by
Modified: 2005-08-01 01:38 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-01 16:34:33
$ rpm -q dia
dia-0.94-alt3cvs20041227

$ dia
dia: symbol lookup error: /usr/lib/dia/libdia.so: undefined symbol:
gnome_i18n_get_language_list
------- Comment #1 From 2005-01-01 22:08:33 -------
fixed in dia-0.94-alt3cvs... 
(временно можно запускать dia-gnome из одноимённого пакета) 
------- Comment #2 From 2005-01-01 23:08:20 -------
(In reply to comment #1)
> fixed in dia-0.94-alt3cvs... 
В каком, каком? Я ж указал:
$ rpm -q dia
dia-0.94-alt3cvs20041227

> (временно можно запускать dia-gnome из одноимённого пакета) 
Спасибо, я догадался.

ЗЫ: В нынешнем виде в пакете dia-gnome НЕТ НИКАКОГО СМЫСЛА.
Все что сейчас в нем находится НЕ ЯВЛЯЕТСЯ gnome-specific.

------- Comment #3 From 2005-01-02 12:48:19 -------
(In reply to comment #2) 
> В каком, каком? Я ж указал: 
> $ rpm -q dia 
> dia-0.94-alt3cvs20041227 
Опечатался - в alt4 конечно. 
  
> > (временно можно запускать dia-gnome из одноимённого пакета)  
> Спасибо, я догадался. 
Я для остальных :) 
 
>  
> ЗЫ: В нынешнем виде в пакете dia-gnome НЕТ НИКАКОГО СМЫСЛА. 
> Все что сейчас в нем находится НЕ ЯВЛЯЕТСЯ gnome-specific. 
Мне просто не нравится тот код, который используется при компиляции без GNOME. 
И потом, в будущем наверное появится что-то более gnome-зависимое, туда и 
попадёт.  
 
 
------- Comment #4 From 2005-01-02 13:12:56 -------
(In reply to comment #3)
  
> > ЗЫ: В нынешнем виде в пакете dia-gnome НЕТ НИКАКОГО СМЫСЛА. 
> > Все что сейчас в нем находится НЕ ЯВЛЯЕТСЯ gnome-specific. 
> Мне просто не нравится тот код, который используется при компиляции без GNOME.

Так какой код не нравиться? С GNOME или без оного?
 
> И потом, в будущем наверное появится что-то более gnome-зависимое, туда и 
> попадёт.  

Зачем он сейчас? Чтоб показать народу как не недо делать? У Вас же .desktop файл
 -- специфика Гнома, как и единственное справочное руководство dia.


------- Comment #5 From 2005-01-02 22:33:34 -------
(In reply to comment #4) 
> Так какой код не нравиться? С GNOME или без оного? 
Без GNOME :) 
 
> Зачем он сейчас? Чтоб показать народу как не недо делать? У Вас же .desktop 
файл 
>  -- специфика Гнома, как и единственное справочное руководство dia. 
Вы конкретно скажите, что вам не нравится. 
Одним хочется gtk-only программу, другим - под gnome. Это ко многим проектам 
относится. Я попытался это решить. Хорошо или плохо - посмотрим. Это просто 
одно из решений проблемы. 
 
------- Comment #6 From 2005-01-02 22:54:05 -------
(In reply to comment #5)
> (In reply to comment #4) 
> > Так какой код не нравиться? С GNOME или без оного? 
> Без GNOME :) 
>  
> > Зачем он сейчас? Чтоб показать народу как не недо делать? У Вас же .desktop 
> файл 
> >  -- специфика Гнома, как и единственное справочное руководство dia. 
> Вы конкретно скажите, что вам не нравится. 

Виталий, я уже два раза сказал, что мне не нравиться.
Еще раз: ВСЕ, абсолютно ВСЕ, что лежит в пакет dia-gnome не является специфичным
для GNOME-программ.

> Одним хочется gtk-only программу, другим - под gnome. Это ко многим проектам 
> относится. 

Не надо обобщать по единичным фактам.

Я попытался это решить. Хорошо или плохо - посмотрим. 

Никак не решили. 

Это просто 
> одно из решений проблемы. 

Никакое это не решение. Рекомендую сразу убрать эту ерунду.

------- Comment #7 From 2005-04-17 20:36:08 -------
Пока посмотрим что будет 
 
------- Comment #8 From 2005-08-01 01:38:24 -------
Проблема запуска исправлена. Пакет dia собирается минималистично. 
Дополнительные возможности, в т.ч. связанные и с GNOME, собраны в пакет 
dia-gnome. 
Содержимое dia-gnome надеюсь улучшить в будущем.