Bug 5853 - ide-cs отправляет сообщение add и remove при каждом обращении к устройству
: ide-cs отправляет сообщение add и remove при каждом обращении к устройству
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std26-up)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 5852 5854
  Show dependency tree
 
Reported: 2005-01-11 10:44 by
Modified: 2005-08-31 03:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-11 10:44:49
при каждом обращении к устройству, работающему через ide-cs мы получаем в
hotplug'е сообщения remove и add, что приводит к невозможности определять
раздел
на таком устройстве в hotplug'е или udev:
Jan 11 08:55:55 rimob default.hotplug[11301]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1404 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11309]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1405 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11321]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1406 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11345]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1409 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11340]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1408 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11360]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1410 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11329]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1407 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11369]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1411 _=/usr/bin/env)
Jan 11 08:55:55 rimob default.hotplug[11381]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1412 _=/usr/bin/env)
Jan 11 08:55:56 rimob default.hotplug[11389]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1413 _=/usr/bin/env)
Jan 11 08:55:56 rimob default.hotplug[10578]: no runnable
/etc/hotplug/block.agent is installed
Jan 11 08:55:56 rimob default.hotplug[11403]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug
HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQ
NUM=1414 _=/usr/bin/env)
Jan 11 08:55:56 rimob default.hotplug[11411]: arguments (block) env
(PHYSDEVPATH=/devices/ide2/2.0 SUBSYSTEM=block OLDPWD=/ DEVPATH=/block/h
de/hde1 PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug HOME=/
SHLVL=2 PHYSDEVDRIVER=ide-disk DEBUG=yes PHYSDEVBUS=ide SEQNUM
=1415 _=/usr/bin/env)
------- Comment #1 From 2005-01-11 10:46:58 -------
reassign to new mantainer
------- Comment #2 From 2005-01-24 12:18:38 -------
Может быть такой патч поможет ?
http://www.ussg.iu.edu/hypermail/linux/kernel/0308.0/1649.html
------- Comment #3 From 2005-01-24 12:28:59 -------
Кстати, в 2.6.10 этот код присутствует.

Может быть достаточно будет добавить в ide-cs.c::ide_attach()
drive->attach = 1;
???
В ide-disk.c есть обработка этого кода, по ощущениям - то что нужно.
------- Comment #4 From 2005-02-10 11:45:13 -------
Fixed in kernel-image-std26-up-2.6.10-alt3.
------- Comment #5 From 2005-05-12 09:56:23 -------
*** Bug 5854 has been marked as a duplicate of this bug. ***