Bug 5860 - wrong requirement
: wrong requirement
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/openoffice.org)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-01-11 17:44 by
Modified: 2005-08-29 01:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-11 17:44:27
$ rpm -qR openoffice.org |grep lang
openoffice.org-lang

А должен требовать openoffice.org-lang = %version-%release

В противном случае ooffice не запускается с жалобой на отсутствие
/usr/lib/OpenOffice.org/program/instdb.ins, что неудивительно, так как
альтернативы могут ссылаться на предыдущую версию.
------- Comment #1 From 2005-01-19 07:09:51 -------
Ага... можно ставить requires на версию виртуального пакета? Я думал, нельзя.
------- Comment #2 From 2005-01-19 09:40:38 -------
Виртуальный пакет тоже может иметь версию. Например:
Provides: aaa = 5.0-alt8

Соответственно и потребовать её можно.
------- Comment #3 From 2005-02-14 21:55:07 -------
Fixed in 1.1.4-alt2