Bug 588 - last shows a fake 0 sec. entry in wtmp before any real user session
: last shows a fake 0 sec. entry in wtmp before any real user session
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/login)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-02-10 15:32 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-02-10 15:32:01
Just look at this output from last, there were no real 0 sec. sessions:

[<a href="mailto:imz@altair" target="_new">imz@altair</a> imz]$ last -20 imz
imz      pts/7        shamrock.office. Sun Feb 10 15:39   still logged in
imz      pts/7        shamrock.office. Sun Feb 10 15:39 - 15:39 (00:00)
imz      pts/5        212.45.20.210    Sun Feb 10 12:29   still logged in
imz      pts/5        212.45.20.210    Sun Feb 10 12:29 - 12:29 (00:00)
imz      pts/9        shamrock.office. Sat Feb  9 23:10 - 23:10 (00:00)
imz      pts/9        shamrock.office. Sat Feb  9 23:10 - 23:10 (00:00)
imz      pts/5        212.45.20.210    Sat Feb  9 21:59 - 23:49 (01:49)
imz      pts/5        212.45.20.210    Sat Feb  9 21:59 - 21:59 (00:00)
imz      pts/24       212.45.20.210    Sat Feb  9 19:47 - 21:36 (01:48)
imz      pts/24       212.45.20.210    Sat Feb  9 19:47 - 19:47 (00:00)
imz      pts/9        212.45.20.210    Sat Feb  9 19:22 - 21:25 (02:02)
imz      pts/9        212.45.20.210    Sat Feb  9 19:22 - 19:22 (00:00)
imz      pts/7        212.45.20.210    Sat Feb  9 18:18 - 18:22 (00:03)
imz      pts/7        212.45.20.210    Sat Feb  9 18:18 - 18:18 (00:00)
imz      pts/7        212.45.20.210    Sat Feb  9 18:16 - 18:18 (00:02)
imz      pts/7        212.45.20.210    Sat Feb  9 18:16 - 18:16 (00:00)
imz      pts/7        212.45.20.210    Sat Feb  9 15:51 - 18:15 (02:24)
imz      pts/7        212.45.20.210    Sat Feb  9 15:51 - 15:51 (00:00)
imz      pts/14       212.45.20.210    Sat Feb  9 02:00 - 02:05 (00:04)
imz      pts/14       212.45.20.210    Sat Feb  9 02:00 - 02:00 (00:00)

wtmp begins Fri Feb  1 04:02:02 2002
[<a href="mailto:imz@altair" target="_new">imz@altair</a> imz]$

The fake 0 sec. sessions make reading the list difficult.

---

---
Probably this is not a bug of last from SysVinit, but I can\'t find a better category for the bug report.

------- Comment #1 From 2002-02-11 15:02:31 -------
No, last is innocent.

The bugs are in sshd/login pam configs.
They do lastlog manipulations and use pam_lastlog - it\'s mutially exclusive.

Default login and sshd configs are affected.

Relocating bug report to login package.
------- Comment #2 From 2002-02-11 15:02:31 -------
No, last is innocent.

The bugs are in sshd/login pam configs.
They do lastlog manipulations and use pam_lastlog - it\'s mutially exclusive.

Default login and sshd configs are affected.

Relocating bug report to login package.
------- Comment #3 From 2002-03-12 19:44:02 -------
Problem fixed in
login-0.60-alt11
openssh-3.0.2p1-alt2
------- Comment #4 From 2002-03-12 19:44:02 -------
Problem fixed in
login-0.60-alt11
openssh-3.0.2p1-alt2