Created attachment 21199 [details] systemctl --user status podman-compose@hello-app podman-compose-1.3.0-alt1 Стенды: ALT Workstation K 10.4 ALT Workstation 10.4 ALT Education 10.4 KDE ALT Education 10.4 XFCE ALT Server 10.4 Шаги воспроизведения: Выполнить: 1.# mkdir hello-app && cd hello-app 2.# cat > docker-compose.yaml <<EOF --- version: '3' services: web: image: gcr.io/google-samples/hello-app:1.0 ports: - "8888:8080" EOF 3. podman-compose systemd --action create-unit 4. podman-compose systemd -a register 5. systemctl --user start podman-compose@hello-app && sleep 5; systemctl --user status podman-compose@hello-app Ожидаемый результат: Сервис успешно запускается Реальный результат: Сервис не запускается. Ошибка: netavark: iptables: No such file or directory
Результат проверки актуальности Состояние: Сервис podman-compose@project не стартует: netavark: iptables: No such file or directory. Описано для podman-compose-1.3.0. В Branch p10 и Sisyphus сейчас 1.5.0; проверка на 1.5.0 не выполнялась. Рекомендация: перепроверить systemctl --user start podman-compose@hello-app в Sisyphus с podman-compose-1.5.0-alt1. Ошибка передана qa-team.
Добрый день 1. Проверьте - установлен ли и какого типа пакет iptables rpm -qa | grep iptables 2. Если в списке нет iptables и iptables-nft Посмотрите доступные пакеты # apt-cache search iptables | grep '^iptables' iptables - Tools for managing Linux kernel packet filtering capabilities iptables-nft - nftables compatibility for iptables, arptables and ebtables ... Если в списке есть iptables-nft установите этот пакет # apt-get install iptables-nft Если только iptables - установите его # apt-get install iptables Проверьте - пропадает ли ошибка после установки пакета